# CVE-2023-41419: Gevent allows remote attacker to escalate privileges

> A remote attacker can escalate privileges by sending a crafted script to the WSGIServer component in the Gevent library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2023
- **Updated:** 25 Nov 2025
- **Also known as:** ALSA-2024:8834, AZL-30058, DEBIAN-CVE-2023-41419, DLA-4377-1, GHSA-x7m3-jprg-wc5g, OESA-2023-1697, OESA-2023-1698, OESA-2023-1699, PYSEC-2023-177, RHSA-2023:7438, RHSA-2024:7421, RHSA-2024:7785, RHSA-2024:8102, RHSA-2024:8105, RHSA-2024:8834, RLSA-2024:8834, ROOT-APP-PYPI-CVE-2023-41419, SUSE-SU-2023:3975-1, SUSE-SU-2023:4009-1, SUSE-SU-2023:4091-1, UBUNTU-CVE-2023-41419, openSUSE-SU-2024:13254-1

## What is CVE-2023-41419?

CVE-2023-41419 is a critical vulnerability in n/a, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.

## Which versions are affected by CVE-2023-41419?

3 open source packages ship an affected version, including gevent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gevent` | PyPI | All versions | 23.9.0 |
| `gevent` | PyPI | All versions | 23.9.0 |
| `gevent` | PyPI | All versions | 23.9.0 |
| `python3-gevent` | AlmaLinux:8 | All versions | 1.2.2-5.el8_10 |
| `python-gevent` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.2.2-5.el8_10 |
| `python-gevent-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.2.2-5.el8_10 |
| `python3-gevent` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.2.2-5.el8_10 |
| `python3-gevent-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.2.2-5.el8_10 |
| `python-gevent` | Red Hat:openstack:17.1::el9 | All versions | 0:21.1.2-2.el9ost |
| `python-gevent-debugsource` | Red Hat:openstack:17.1::el9 | All versions | 0:21.1.2-2.el9ost |
| `python3-gevent` | Red Hat:openstack:17.1::el9 | All versions | 0:21.1.2-2.el9ost |
| `python3-gevent-debuginfo` | Red Hat:openstack:17.1::el9 | All versions | 0:21.1.2-2.el9ost |
| `python-gevent` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:1.2.2-5.el8_2 |
| `python-gevent-debugsource` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:1.2.2-5.el8_2 |
| `python3-gevent` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:1.2.2-5.el8_2 |
| `python3-gevent-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:1.2.2-5.el8_2 |
| `python-gevent` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python-gevent-debugsource` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent-debuginfo` | Red Hat:rhel_aus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python-gevent` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python-gevent-debugsource` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python3-gevent` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python3-gevent-debuginfo` | Red Hat:rhel_aus:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python-gevent` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python-gevent-debugsource` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent-debuginfo` | Red Hat:rhel_e4s:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python-gevent` | Red Hat:rhel_e4s:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python-gevent-debugsource` | Red Hat:rhel_e4s:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python3-gevent` | Red Hat:rhel_e4s:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python3-gevent-debuginfo` | Red Hat:rhel_e4s:8.6::appstream | All versions | 0:1.2.2-5.el8_6 |
| `python-gevent` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.2.2-5.el8_8 |
| `python-gevent-debugsource` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.2.2-5.el8_8 |
| `python3-gevent` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.2.2-5.el8_8 |
| `python3-gevent-debuginfo` | Red Hat:rhel_eus:8.8::appstream | All versions | 0:1.2.2-5.el8_8 |
| `python-gevent` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python-gevent-debugsource` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |
| `python3-gevent-debuginfo` | Red Hat:rhel_tus:8.4::appstream | All versions | 0:1.2.2-5.el8_4 |

Products: Gevent Gevent.

## How do I fix CVE-2023-41419?

Upgrade gevent to 23.9.0 or later.

## Is CVE-2023-41419 being exploited?

There is no known exploitation of CVE-2023-41419 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41419 and fix it if it is affected.

What it is: CVE-2023-41419 is a critical vulnerability in n/a, published on 25 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41419 in the wild and no public exploit code.

Affected packages and fixed versions:
- gevent (PyPI): affected all versions; fixed in 23.9.0
- gevent (PyPI): affected all versions; fixed in 23.9.0
- gevent (PyPI): affected all versions; fixed in 23.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41419/ (Markdown: https://insights.sbomify.com/CVE-2023-41419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41419
- OSV: https://osv.dev/vulnerability/CVE-2023-41419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41419/
Summaries are generated and may contain mistakes; the official description above is the record.
