{"answers":{"affected":"4 open source packages ship an affected version, including froala/wysiwyg-editor and froala-editor. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41592 exists.","fix":"Upgrade froala/wysiwyg-editor to 4.1.4 or later.","what":"CVE-2023-41592 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-41592 and fix it if it is affected.\n\nWhat it is: CVE-2023-41592 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41592 exists.\n\nAffected packages and fixed versions:\n- froala/wysiwyg-editor (Packagist): affected from 4.0.1; fixed in 4.1.4\n- froala/wysiwyg-editor (Packagist): affected from 4.0.1; fixed in 4.1.4\n- froala-editor (npm): affected from 4.0.1; fixed in 4.1.4\n- froala-editor (npm): affected from 4.0.1; fixed in 4.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41592/ (Markdown: https://insights.sbomify.com/CVE-2023-41592/index.md)","id":"CVE-2023-41592","markdown":"https://insights.sbomify.com/CVE-2023-41592/index.md","name":"CVE-2023-41592","record":{"aliases":["GHSA-hvpq-7vcc-5hj5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Froala Editor","requires_auth":"low_privilege","summary":"An XSS vulnerability in Froala Editor allows attackers to inject malicious scripts, potentially leading to code execution in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"froala_editor","vendor":"froala"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.","ecosystems":["Packagist","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Froala Editor Cross-site Scripting vulnerability","id":"CVE-2023-41592","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-41593"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["4.0.1"],"last_affected":[],"package":"froala/wysiwyg-editor","purl":null,"source":"GHSA-hvpq-7vcc-5hj5"},{"ecosystem":"Packagist","fixed":["4.1.4"],"introduced":["4.0.1"],"last_affected":[],"package":"froala/wysiwyg-editor","purl":"pkg:composer/froala/wysiwyg-editor","source":"GHSA-hvpq-7vcc-5hj5"},{"ecosystem":"npm","fixed":["4.1.4"],"introduced":["4.0.1"],"last_affected":[],"package":"froala-editor","purl":null,"source":"GHSA-hvpq-7vcc-5hj5"},{"ecosystem":"npm","fixed":["4.1.4"],"introduced":["4.0.1"],"last_affected":[],"package":"froala-editor","purl":"pkg:npm/froala-editor","source":"GHSA-hvpq-7vcc-5hj5"}],"prev":{"headline":"Other in n/a","id":"CVE-2023-41591"},"products":["n/a"],"published":"2023-09-14","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-43263","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-42426","kev_date_added":null,"published":"2023-09-25"},{"cvss_score":6.1,"headline":"Cross site scripting in froala-editor","id":"CVE-2020-22864","kev_date_added":null,"published":"2021-10-26"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Froala Editor","id":"CVE-2021-30109","kev_date_added":null,"published":"2021-04-05"},{"cvss_score":6.1,"headline":"Froala WYSIWYG Editor XSS Vulnerability","id":"CVE-2020-26523","kev_date_added":null,"published":"2020-10-02"},{"cvss_score":6.1,"headline":"DOM-based cross-site scripting in Froala Editor","id":"CVE-2019-19935","kev_date_added":null,"published":"2020-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-25","vendors":["n/a"]},"summary":"An XSS vulnerability in Froala Editor allows attackers to inject malicious scripts, potentially leading to code execution in user browsers.","url":"https://insights.sbomify.com/CVE-2023-41592/"}