# CVE-2023-41592: Froala Editor Cross-site Scripting vulnerability

> An XSS vulnerability in Froala Editor allows attackers to inject malicious scripts, potentially leading to code execution in user browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-hvpq-7vcc-5hj5

## What is CVE-2023-41592?

CVE-2023-41592 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-41592?

4 open source packages ship an affected version, including froala/wysiwyg-editor and froala-editor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froala/wysiwyg-editor` | Packagist | From 4.0.1 | 4.1.4 |
| `froala/wysiwyg-editor` | Packagist | From 4.0.1 | 4.1.4 |
| `froala-editor` | npm | From 4.0.1 | 4.1.4 |
| `froala-editor` | npm | From 4.0.1 | 4.1.4 |

Products: Froala Froala Editor.

## How do I fix CVE-2023-41592?

Upgrade froala/wysiwyg-editor to 4.1.4 or later.

## Is CVE-2023-41592 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41592 exists.

## Other vulnerabilities in n/a

- [CVE-2023-43263](https://insights.sbomify.com/CVE-2023-43263/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-42426](https://insights.sbomify.com/CVE-2023-42426/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2020-22864](https://insights.sbomify.com/CVE-2020-22864/): Cross site scripting in froala-editor (medium 6.1)
- [CVE-2021-30109](https://insights.sbomify.com/CVE-2021-30109/): Cross-site Scripting in Froala Editor (medium 6.1)
- [CVE-2020-26523](https://insights.sbomify.com/CVE-2020-26523/): Froala WYSIWYG Editor XSS Vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41592 and fix it if it is affected.

What it is: CVE-2023-41592 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41592 exists.

Affected packages and fixed versions:
- froala/wysiwyg-editor (Packagist): affected from 4.0.1; fixed in 4.1.4
- froala/wysiwyg-editor (Packagist): affected from 4.0.1; fixed in 4.1.4
- froala-editor (npm): affected from 4.0.1; fixed in 4.1.4
- froala-editor (npm): affected from 4.0.1; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41592/ (Markdown: https://insights.sbomify.com/CVE-2023-41592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41592
- OSV: https://osv.dev/vulnerability/CVE-2023-41592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41592/
Summaries are generated and may contain mistakes; the official description above is the record.
