CVE-2023-4177 EmpowerID Multi-Factor Authentication Code information disclosure

Low 2.6 Published Updated

An attacker with permissions can exploit a flaw in the MFA code handler to disclose sensitive information, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-4177?

CVE-2023-4177 is a low-severity vulnerability in EmpowerID, published on 6 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in EmpowerID up to 7.205.0.0. It has been rated as problematic. This issue affects some unknown processing of the component Multi-Factor Authentication Code Handler. The manipulation leads to information disclosure. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 7.205.0.1 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-236213 was assigned to this vulnerability.

Weakness: CWE-345, CWE-200

Which versions are affected by CVE-2023-4177?

It affects 1 product.

Products include Empowerid Empowerid.

How do I fix CVE-2023-4177?

No fix has been published for CVE-2023-4177 yet. Limit exposure of the affected software until one is available.

Is CVE-2023-4177 being exploited?

There is no known exploitation of CVE-2023-4177 in the wild and no public exploit code.

Sources

Also known as GHSA-8984-8j8r-cc3q.

Is CVE-2023-4177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free