{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-4177 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-4177 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-4177 is a low-severity vulnerability in EmpowerID, published on 6 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-4177 and fix it if it is affected.\n\nWhat it is: CVE-2023-4177 is a low-severity vulnerability in EmpowerID, published on 6 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-4177 in the wild and no public exploit code.\n\nAffected product: EmpowerID. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4177/ (Markdown: https://insights.sbomify.com/CVE-2023-4177/index.md)","id":"CVE-2023-4177","markdown":"https://insights.sbomify.com/CVE-2023-4177/index.md","name":"CVE-2023-4177","record":{"aliases":["GHSA-8984-8j8r-cc3q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"EmpowerID IAM","requires_auth":"low_privilege","summary":"An attacker with permissions can exploit a flaw in the MFA code handler to disclose sensitive information, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"empowerid","vendor":"empowerid"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability was found in EmpowerID up to 7.205.0.0. It has been rated as problematic. This issue affects some unknown processing of the component Multi-Factor Authentication Code Handler. The manipulation leads to information disclosure. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 7.205.0.1 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-236213 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"EmpowerID Multi-Factor Authentication Code information disclosure","id":"CVE-2023-4177","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"Authentication Bypass in Neutron Smart VMS","id":"CVE-2023-4178"},"packages":[],"prev":{"headline":"SourceCodester Hospital Management System appointmentapproval.php sql injection","id":"CVE-2023-4176"},"products":["EmpowerID"],"published":"2023-08-06","related":[{"cvss_score":9.1,"headline":"Auth bypass in n/a","id":"CVE-2023-40260","kev_date_added":null,"published":"2023-08-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"An attacker with permissions can exploit a flaw in the MFA code handler to disclose sensitive information, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2023-4177/"}