# CVE-2023-4177: EmpowerID Multi-Factor Authentication Code information disclosure

> An attacker with permissions can exploit a flaw in the MFA code handler to disclose sensitive information, requiring an upgrade to mitigate.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Aug 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-8984-8j8r-cc3q

## What is CVE-2023-4177?

CVE-2023-4177 is a low-severity vulnerability in EmpowerID, published on 6 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in EmpowerID up to 7.205.0.0. It has been rated as problematic. This issue affects some unknown processing of the component Multi-Factor Authentication Code Handler. The manipulation leads to information disclosure. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 7.205.0.1 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-236213 was assigned to this vulnerability.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-4177?

It affects 1 product.


Products: Empowerid Empowerid.

## How do I fix CVE-2023-4177?

No fix has been published for CVE-2023-4177 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-4177 being exploited?

There is no known exploitation of CVE-2023-4177 in the wild and no public exploit code.

## Other vulnerabilities in EmpowerID

- [CVE-2023-40260](https://insights.sbomify.com/CVE-2023-40260/): Auth bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4177 and fix it if it is affected.

What it is: CVE-2023-4177 is a low-severity vulnerability in EmpowerID, published on 6 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4177 in the wild and no public exploit code.

Affected product: EmpowerID. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4177/ (Markdown: https://insights.sbomify.com/CVE-2023-4177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4177
- OSV: https://osv.dev/vulnerability/CVE-2023-4177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4177/
Summaries are generated and may contain mistakes; the official description above is the record.
