CVE-2023-41835 Apache Struts: excessive disk usage
Attackers can cause excessive disk usage by sending multipart requests with oversized fields, leading to potential denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-41835?
CVE-2023-41835 is a high-severity denial of service vulnerability in Apache Struts, published on 5 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.
Weakness: CWE-459
Which versions are affected by CVE-2023-41835?
6 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | All versions | 2.5.32 |
org.apache.struts:struts2-core Maven | All versions | 2.5.32 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.2 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.2 |
org.apache.struts:struts2-core Maven | From 6.2.0 | 6.3.0.1 |
org.apache.struts:struts2-core Maven | From 6.2.0 | 6.3.0.1 |
Products include Apache Struts.
How do I fix CVE-2023-41835?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.5.32, 6.1.2.2 or 6.3.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-41835 being exploited?
There is no known exploitation of CVE-2023-41835 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-729q-fcgp-r5xh.