# CVE-2023-41879: Magento LTS's guest order "protect code" can be brute-forced too easily

> Attackers can brute-force weak guest order protection codes to access unauthorized order details in Magento LTS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-9358-cpvx-c2qp

## What is CVE-2023-41879?

CVE-2023-41879 is a high-severity vulnerability in OpenMage magento-lts, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Magento LTS is the official OpenMage LTS codebase. Guest orders may be viewed without authentication using a "guest-view" cookie which contains the order's "protect_code". This code is 6 hexadecimal characters which is arguably not enough to prevent a brute-force attack. Exposing each order would require a separate brute force attack. This issue has been patched in versions 19.5.1 and 20.1.1.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2023-41879?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.5.1 |
| `openmage/magento-lts` | Packagist | All versions | 19.5.1 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.1.1 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.1.1 |

Products: Openmage Magento.

## How do I fix CVE-2023-41879?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.5.1 or 20.1.1.

## Is CVE-2023-41879 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41879 exists.

## Other vulnerabilities in OpenMage magento-lts

- [CVE-2021-21426](https://insights.sbomify.com/CVE-2021-21426/): Fixes a bug in Zend Framework's Stream HTTP Wrapper (critical 9.8)
- [CVE-2021-21427](https://insights.sbomify.com/CVE-2021-21427/): Backport for CVE-2021-21024 Blind SQLi from Magento 2 (critical 9.1)
- [CVE-2021-41144](https://insights.sbomify.com/CVE-2021-41144/): OpenMage LTS authenticated remote code execution through layout update (high 8.8)
- [CVE-2026-40488](https://insights.sbomify.com/CVE-2026-40488/): OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution (high 8.7)
- [CVE-2026-25524](https://insights.sbomify.com/CVE-2026-25524/): OpenMage LTS's Phar Deserialization leads to Remote Code Execution (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41879 and fix it if it is affected.

What it is: CVE-2023-41879 is a high-severity vulnerability in OpenMage magento-lts, published on 11 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41879 exists.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.5.1
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.5.1
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.1.1
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41879/ (Markdown: https://insights.sbomify.com/CVE-2023-41879/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41879
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41879
- OSV: https://osv.dev/vulnerability/CVE-2023-41879

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41879/
Summaries are generated and may contain mistakes; the official description above is the record.
