{"answers":{"affected":"6 open source packages ship an affected version, including Sustainsys.Saml2 and Kentor.AuthServices. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41890 in the wild and no public exploit code.","fix":"Upgrade Sustainsys.Saml2 to a fixed version for your release line: 1.0.3 or 2.9.2.","what":"CVE-2023-41890 is a high-severity authentication bypass vulnerability in Sustainsys Saml2, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41890 and fix it if it is affected.\n\nWhat it is: CVE-2023-41890 is a high-severity authentication bypass vulnerability in Sustainsys Saml2, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41890 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Sustainsys.Saml2 (NuGet): affected all versions; fixed in 1.0.3\n- Sustainsys.Saml2 (NuGet): affected all versions; fixed in 1.0.3\n- Sustainsys.Saml2 (NuGet): affected from 2.0.0; fixed in 2.9.2\n- Sustainsys.Saml2 (NuGet): affected from 2.0.0; fixed in 2.9.2\n- Kentor.AuthServices (NuGet): affected all versions up to 0.23.0; no fix listed\n- Kentor.AuthServices (NuGet): affected all versions up to 0.23.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41890/ (Markdown: https://insights.sbomify.com/CVE-2023-41890/index.md)","id":"CVE-2023-41890","markdown":"https://insights.sbomify.com/CVE-2023-41890/index.md","name":"CVE-2023-41890","record":{"aliases":["GHSA-fv2h-753j-9g39"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SAML2 authentication library","requires_auth":"none","summary":"Insufficient issuer validation in Sustainsys.Saml2 allows malicious providers or users to bypass authentication checks, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"saml2","vendor":"sustainsys"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-294","name":"Authentication Bypass by Capture-replay"},{"id":"CWE-289","name":"Authentication Bypass by Alternate Name"}],"description":"Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. \nPrior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation","id":"CVE-2023-41890","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":6,"n_references":3,"next":{"headline":"FlyteAdmin SQL Injection in List Filters","id":"CVE-2023-41891"},"packages":[{"ecosystem":"NuGet","fixed":[],"introduced":["0"],"last_affected":["0.23.0"],"package":"Kentor.AuthServices","purl":null,"source":"GHSA-fv2h-753j-9g39"},{"ecosystem":"NuGet","fixed":[],"introduced":["0"],"last_affected":["0.23.0"],"package":"Kentor.AuthServices","purl":"pkg:nuget/Kentor.AuthServices","source":"GHSA-fv2h-753j-9g39"},{"ecosystem":"NuGet","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"Sustainsys.Saml2","purl":null,"source":"GHSA-fv2h-753j-9g39"},{"ecosystem":"NuGet","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"Sustainsys.Saml2","purl":"pkg:nuget/Sustainsys.Saml2","source":"GHSA-fv2h-753j-9g39"},{"ecosystem":"NuGet","fixed":["2.9.2"],"introduced":["2.0.0"],"last_affected":[],"package":"Sustainsys.Saml2","purl":null,"source":"GHSA-fv2h-753j-9g39"},{"ecosystem":"NuGet","fixed":["2.9.2"],"introduced":["2.0.0"],"last_affected":[],"package":"Sustainsys.Saml2","purl":"pkg:nuget/Sustainsys.Saml2","source":"GHSA-fv2h-753j-9g39"}],"prev":{"headline":"Late-Unicode normalization vulnerability in SHIRASAGI","id":"CVE-2023-41889"},"products":["Saml2"],"published":"2023-09-19","related":[{"cvss_score":8.2,"headline":"Missing Token Replay Detection","id":"CVE-2020-5261","kev_date_added":null,"published":"2020-03-25"},{"cvss_score":6.5,"headline":"Subject Confirmation Method not validated in Saml2 Authentication Services for ASP.NET","id":"CVE-2020-5268","kev_date_added":null,"published":"2020-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["Sustainsys"]},"summary":"Insufficient issuer validation in Sustainsys.Saml2 allows malicious providers or users to bypass authentication checks, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2023-41890/"}