{"answers":{"affected":"3 open source packages ship an affected version, including github.com/flyteorg/flyteadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41891 in the wild and no public exploit code.","fix":"Upgrade github.com/flyteorg/flyteadmin to 1.1.124 or later.","what":"CVE-2023-41891 is a low-severity SQL injection vulnerability in flyteorg flyteadmin, published on 30 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41891 and fix it if it is affected.\n\nWhat it is: CVE-2023-41891 is a low-severity SQL injection vulnerability in flyteorg flyteadmin, published on 30 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41891/ (Markdown: https://insights.sbomify.com/CVE-2023-41891/index.md)","id":"CVE-2023-41891","markdown":"https://insights.sbomify.com/CVE-2023-41891/index.md","name":"CVE-2023-41891","record":{"aliases":["GHSA-r847-6w6h-r8g4","GO-2023-2162"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"FlyteAdmin control plane","requires_auth":"low_privilege","summary":"Authenticated attackers can inject SQL via list filters in FlyteAdmin to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flyteadmin","vendor":"flyte"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. Prior to version 1.1.124, list endpoints on FlyteAdmin have a SQL vulnerability where a malicious user can send a REST request with custom SQL statements as list filters. The attacker needs to have access to the FlyteAdmin installation, typically either behind a VPN or authentication. Version 1.1.124 contains a patch for this issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FlyteAdmin SQL Injection in List Filters","id":"CVE-2023-41891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"sql_injection","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Craft CMS Remote Code Execution vulnerability","id":"CVE-2023-41892"},"packages":[{"ecosystem":"Go","fixed":["1.1.124"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":null,"source":"GHSA-r847-6w6h-r8g4"},{"ecosystem":"Go","fixed":["1.1.124"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":"pkg:golang/github.com/flyteorg/flyteadmin","source":"GHSA-r847-6w6h-r8g4"},{"ecosystem":"Go","fixed":["1.1.124"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":"pkg:golang/github.com/flyteorg/flyteadmin","source":"GO-2023-2162"}],"prev":{"headline":"Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation","id":"CVE-2023-41890"},"products":["flyteadmin"],"published":"2023-10-30","related":[{"cvss_score":6.5,"headline":"Insufficient AccessToken Expiration Check in FlyteAdmin","id":"CVE-2022-31145","kev_date_added":null,"published":"2022-07-13"},{"cvss_score":4.8,"headline":"Default OAuth Authorization Server secret in FlyteAdmin","id":"CVE-2022-39273","kev_date_added":null,"published":"2022-10-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-06","vendors":["flyteorg"]},"summary":"Authenticated attackers can inject SQL via list filters in FlyteAdmin to read or modify database contents.","url":"https://insights.sbomify.com/CVE-2023-41891/"}