# CVE-2023-41891: FlyteAdmin SQL Injection in List Filters

> Authenticated attackers can inject SQL via list filters in FlyteAdmin to read or modify database contents.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2023
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-r847-6w6h-r8g4, GO-2023-2162

## What is CVE-2023-41891?

CVE-2023-41891 is a low-severity SQL injection vulnerability in flyteorg flyteadmin, published on 30 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. Prior to version 1.1.124, list endpoints on FlyteAdmin have a SQL vulnerability where a malicious user can send a REST request with custom SQL statements as list filters. The attacker needs to have access to the FlyteAdmin installation, typically either behind a VPN or authentication. Version 1.1.124 contains a patch for this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-41891?

3 open source packages ship an affected version, including github.com/flyteorg/flyteadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.124 |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.124 |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.124 |

Products: Flyte Flyteadmin.

## How do I fix CVE-2023-41891?

Upgrade github.com/flyteorg/flyteadmin to 1.1.124 or later.

## Is CVE-2023-41891 being exploited?

There is no known exploitation of CVE-2023-41891 in the wild and no public exploit code.

## Other vulnerabilities in flyteorg flyteadmin

- [CVE-2022-31145](https://insights.sbomify.com/CVE-2022-31145/): Insufficient AccessToken Expiration Check in FlyteAdmin (medium 6.5)
- [CVE-2022-39273](https://insights.sbomify.com/CVE-2022-39273/): Default OAuth Authorization Server secret in FlyteAdmin (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41891 and fix it if it is affected.

What it is: CVE-2023-41891 is a low-severity SQL injection vulnerability in flyteorg flyteadmin, published on 30 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41891 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.124

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41891/ (Markdown: https://insights.sbomify.com/CVE-2023-41891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41891
- OSV: https://osv.dev/vulnerability/CVE-2023-41891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41891/
Summaries are generated and may contain mistakes; the official description above is the record.
