CVE-2023-41892 Craft CMS Remote Code Execution vulnerability

Critical 10.0 Published Updated

Attackers can execute arbitrary code on Craft CMS installations, requiring immediate upgrade to mitigate this high-impact vulnerability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41892?

CVE-2023-41892 is a critical code injection vulnerability in Craftcms Craft Cms, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Craft CMS is a platform for creating digital experiences. This is a high-impact, low-complexity attack vector. Users running Craft installations before 4.4.15 are encouraged to update to at least that version to mitigate the issue. This issue has been fixed in Craft CMS 4.4.15.

Weakness: CWE-94

Which versions are affected by CVE-2023-41892?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.

PackageAffectedFixed in
craftcms/cms PackagistFrom 4.0.0-RC14.4.15
craftcms/cms PackagistFrom 4.0.0-RC14.4.15

Products include Craftcms Craft Cms.

How do I fix CVE-2023-41892?

Upgrade craftcms/cms to 4.4.15 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-41892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41892 exists.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 7 proofs of concept on GitHub.

All Craftcms Craft Cms vulnerabilities

Sources

Also known as GHSA-4w8r-3xrw-v25g.

Is CVE-2023-41892 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free