# CVE-2023-41892: Craft CMS Remote Code Execution vulnerability

> Attackers can execute arbitrary code on Craft CMS installations, requiring immediate upgrade to mitigate this high-impact vulnerability.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-4w8r-3xrw-v25g

## What is CVE-2023-41892?

CVE-2023-41892 is a critical code injection vulnerability in Craftcms Craft Cms, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft CMS is a platform for creating digital experiences. This is a high-impact, low-complexity attack vector. Users running Craft installations before 4.4.15 are encouraged to update to at least that version to mitigate the issue. This issue has been fixed in Craft CMS 4.4.15.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-41892?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.4.15 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.4.15 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2023-41892?

Upgrade craftcms/cms to 4.4.15 or later.

## Is CVE-2023-41892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41892 exists.

Public exploit code:

- Exploit for CVE-2023-41892 (github_poc): https://github.com/0xfalafel/CraftCMS_CVE-2023-41892
- CVE-2023-41892 Reverse Shell (github_poc): https://github.com/diegaccio/Craft-CMS-Exploit
- CVE-2023-41892 - Craft CMS Remote Code Execution (RCE) (github_poc): https://github.com/zaenhaxor/CVE-2023-41892
- Craft CMS unauthenticated Remote Code Execution (RCE) (metasploit)
- A Craft CMS vulnerability that allows Remote Code Execution (RCE). (github_poc): https://github.com/acesoyeo/CVE-2023-41892
- https://github.com/CERTologists/HTTP-Request-for-PHP-object-injection-attack-on-CVE-2023-41892 (github_poc): https://github.com/CERTologists/HTTP-Request-for-PHP-object-injection-attack-on-CVE-2023-41892

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2021-27903](https://insights.sbomify.com/CVE-2021-27903/): Craft CMS Remote Code Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41892 and fix it if it is affected.

What it is: CVE-2023-41892 is a critical code injection vulnerability in Craftcms Craft Cms, published on 13 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-41892 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.4.15
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.4.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41892/ (Markdown: https://insights.sbomify.com/CVE-2023-41892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41892
- OSV: https://osv.dev/vulnerability/CVE-2023-41892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41892/
Summaries are generated and may contain mistakes; the official description above is the record.
