# CVE-2023-41893: Account takeover via auth_callback login in Home Assistant Core


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 19 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-qhhj-7hrc-gqj5, PYSEC-2023-214

## What is CVE-2023-41893?

CVE-2023-41893 is a medium-severity vulnerability in home-assistant core, published on 19 Oct 2023. 

### Official description

Home assistant is an open source home automation. The audit team’s analyses confirmed that the `redirect_uri` and `client_id` are alterable when logging in. Consequently, the code parameter utilized to fetch the `access_token` post-authentication will be sent to the URL specified in the aforementioned parameters. Since an arbitrary URL is permitted and `homeassistant.local` represents the preferred, default domain likely used and trusted by many users, an attacker could leverage this weakness to manipulate a user and retrieve account access. Notably, this attack strategy is plausible if the victim has exposed their Home Assistant to the Internet, since after acquiring the victim’s `access_token` the adversary would need to utilize it directly towards the instance to achieve any pertinent malicious actions. To achieve this compromise attempt, the attacker must send a link with a `redirect_uri` that they control to the victim’s own Home Assistant instance. In the eventuality the victim authenticates via said link, the attacker would obtain code sent to the specified URL in `redirect_uri`, which can then be leveraged to fetch an `access_token`. Pertinently, an attacker could increase the efficacy of this strategy by registering a near identical domain to `homeassistant.local`, which at first glance may appear legitimate and thereby obfuscate any malicious intentions. This issue has been addressed in version 2023.9.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-41893?

3 open source packages ship an affected version, including homeassistant. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `homeassistant` | PyPI | All versions | 2023.9.0 |
| `homeassistant` | PyPI | All versions | 2023.9.0 |
| `homeassistant` | PyPI | All versions | 2023.9.0 |

Products: Home-Assistant Home-Assistant.

## How do I fix CVE-2023-41893?

Upgrade homeassistant to 2023.9.0 or later.

## Is CVE-2023-41893 being exploited?

There is no known exploitation of CVE-2023-41893 in the wild and no public exploit code.

## Other vulnerabilities in home-assistant core

- [CVE-2023-27482](https://insights.sbomify.com/CVE-2023-27482/): Auth bypass in core (critical 10.0)
- [CVE-2023-41895](https://insights.sbomify.com/CVE-2023-41895/): Cross-site Scripting via auth_callback login in Home Assistant Core (high 8.8)
- [CVE-2023-41897](https://insights.sbomify.com/CVE-2023-41897/): Lack of XFO header allows clickjacking in Home Assistant Core (high 8.8)
- [CVE-2026-54317](https://insights.sbomify.com/CVE-2026-54317/): Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN (high 7.6)
- [CVE-2020-36517](https://insights.sbomify.com/CVE-2020-36517/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41893 and fix it if it is affected.

What it is: CVE-2023-41893 is a medium-severity vulnerability in home-assistant core, published on 19 Oct 2023. 
Exploitation: There is no known exploitation of CVE-2023-41893 in the wild and no public exploit code.

Affected packages and fixed versions:
- homeassistant (PyPI): affected all versions; fixed in 2023.9.0
- homeassistant (PyPI): affected all versions; fixed in 2023.9.0
- homeassistant (PyPI): affected all versions; fixed in 2023.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41893/ (Markdown: https://insights.sbomify.com/CVE-2023-41893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41893
- OSV: https://osv.dev/vulnerability/CVE-2023-41893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41893/
Summaries are generated and may contain mistakes; the official description above is the record.
