CVE-2023-41900 Jetty's OpenId Revoked authentication allows one request
Attackers can bypass authentication in Jetty OpenIdAuthenticator when using a nested LoginService that revokes users, allowing unauthorized access on the current request.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-41900?
CVE-2023-41900 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 15 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.
Which versions are affected by CVE-2023-41900?
6 open source packages ship an affected version, including org.eclipse.jetty:jetty-openid. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty:jetty-openid Maven | From 10.0.0 | 10.0.16 |
org.eclipse.jetty:jetty-openid Maven | From 10.0.0 | 10.0.16 |
org.eclipse.jetty:jetty-openid Maven | From 11.0.0 | 11.0.16 |
org.eclipse.jetty:jetty-openid Maven | From 11.0.0 | 11.0.16 |
org.eclipse.jetty:jetty-openid Maven | From 9.4.21 | 9.4.52.v20230823 |
org.eclipse.jetty:jetty-openid Maven | From 9.4.21 | 9.4.52.v20230823 |
Products include Debian Debian Linux, Eclipse Jetty.
How do I fix CVE-2023-41900?
Upgrade org.eclipse.jetty:jetty-openid to a fixed version for your release line: 10.0.16, 11.0.16 or 9.4.52.v20230823.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-41900 being exploited?
There is no known exploitation of CVE-2023-41900 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-QL45370, DEBIAN-CVE-2023-41900, GHSA-pwh8-58vv-vw48, UBUNTU-CVE-2023-41900.