# CVE-2023-41900: Jetty's OpenId Revoked authentication allows one request

> Attackers can bypass authentication in Jetty OpenIdAuthenticator when using a nested LoginService that revokes users, allowing unauthorized access on the current request.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2026-QL45370, DEBIAN-CVE-2023-41900, GHSA-pwh8-58vv-vw48, UBUNTU-CVE-2023-41900

## What is CVE-2023-41900?

CVE-2023-41900 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 15 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.

Weakness: CWE-287 (Improper Authentication), CWE-1390 (Weak Authentication)

## Which versions are affected by CVE-2023-41900?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-openid. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-openid` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty:jetty-openid` | Maven | From 10.0.0 | 10.0.16 |
| `org.eclipse.jetty:jetty-openid` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty:jetty-openid` | Maven | From 11.0.0 | 11.0.16 |
| `org.eclipse.jetty:jetty-openid` | Maven | From 9.4.21 | 9.4.52.v20230823 |
| `org.eclipse.jetty:jetty-openid` | Maven | From 9.4.21 | 9.4.52.v20230823 |

Products: Debian Debian Linux, Eclipse Jetty.

## How do I fix CVE-2023-41900?

Upgrade org.eclipse.jetty:jetty-openid to a fixed version for your release line: 10.0.16, 11.0.16 or 9.4.52.v20230823.

## Is CVE-2023-41900 being exploited?

There is no known exploitation of CVE-2023-41900 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41900 and fix it if it is affected.

What it is: CVE-2023-41900 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 15 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41900 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-openid (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty:jetty-openid (Maven): affected from 10.0.0; fixed in 10.0.16
- org.eclipse.jetty:jetty-openid (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty:jetty-openid (Maven): affected from 11.0.0; fixed in 11.0.16
- org.eclipse.jetty:jetty-openid (Maven): affected from 9.4.21; fixed in 9.4.52.v20230823
- org.eclipse.jetty:jetty-openid (Maven): affected from 9.4.21; fixed in 9.4.52.v20230823

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41900/ (Markdown: https://insights.sbomify.com/CVE-2023-41900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41900
- OSV: https://osv.dev/vulnerability/CVE-2023-41900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41900/
Summaries are generated and may contain mistakes; the official description above is the record.
