CVE-2023-41916 Apache Linkis DataSource allows arbitrary file reading

Medium 6.5 Published Updated

An authenticated attacker can read arbitrary files by configuring malicious JDBC parameters in the DataSource Manager module.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-41916?

CVE-2023-41916 is a medium-severity path traversal vulnerability in Apache Linkis DataSource, published on 15 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Linkis =1.4.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will trigger arbitrary file reading. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis = 1.4.0 will be affected.  We recommend users upgrade the version of Linkis to version 1.5.0.

Weakness: CWE-552

Which versions are affected by CVE-2023-41916?

2 open source packages ship an affected version, including org.apache.linkis:linkis-datasource. It affects 1 product.

PackageAffectedFixed in
org.apache.linkis:linkis-datasource MavenFrom 1.4.01.6.0
org.apache.linkis:linkis-datasource MavenFrom 1.4.01.6.0

Products include Apache Linkis.

How do I fix CVE-2023-41916?

Upgrade org.apache.linkis:linkis-datasource to 1.6.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-41916 being exploited?

There is no known exploitation of CVE-2023-41916 in the wild and no public exploit code.

Sources

Also known as GHSA-f22j-9j59-33j4.

Is CVE-2023-41916 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free