{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:ssh2easy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-41939 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:ssh2easy to 1.6 or later.","what":"CVE-2023-41939 is a high-severity missing authorization vulnerability in Jenkins SSH2 Easy Plugin, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-41939 and fix it if it is affected.\n\nWhat it is: CVE-2023-41939 is a high-severity missing authorization vulnerability in Jenkins SSH2 Easy Plugin, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-41939 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:ssh2easy (Maven): affected all versions; fixed in 1.6\n- org.jenkins-ci.plugins:ssh2easy (Maven): affected all versions; fixed in 1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-41939/ (Markdown: https://insights.sbomify.com/CVE-2023-41939/index.md)","id":"CVE-2023-41939","markdown":"https://insights.sbomify.com/CVE-2023-41939/index.md","name":"CVE-2023-41939","record":{"aliases":["GHSA-4gh2-m88h-8cj8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins SSH2 Easy Plugin","requires_auth":"low_privilege","summary":"Users formerly granted optional permissions can access functionality they are no longer entitled to due to missing permission verification.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"ssh2_easy","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-281","name":"Improper Preservation of Permissions"}],"description":"Jenkins SSH2 Easy Plugin 1.4 and earlier does not verify that permissions configured to be granted are enabled, potentially allowing users formerly granted (typically optional permissions, like Overall/Manage) to access functionality they're no longer entitled to.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Disabled permissions can be granted by Jenkins SSH2 Easy Plugin","id":"CVE-2023-41939","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins TAP Plugin","id":"CVE-2023-41940"},"packages":[{"ecosystem":"Maven","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh2easy","purl":null,"source":"GHSA-4gh2-m88h-8cj8"},{"ecosystem":"Maven","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh2easy","purl":"pkg:maven/org.jenkins-ci.plugins/ssh2easy","source":"GHSA-4gh2-m88h-8cj8"}],"prev":{"headline":"CSRF vulnerability in Jenkins Ivy Plugin","id":"CVE-2023-41938"},"products":["Jenkins SSH2 Easy Plugin"],"published":"2023-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-26","vendors":["Jenkins Project"]},"summary":"Users formerly granted optional permissions can access functionality they are no longer entitled to due to missing permission verification.","url":"https://insights.sbomify.com/CVE-2023-41939/"}