# CVE-2023-41939: Disabled permissions can be granted by Jenkins SSH2 Easy Plugin

> Users formerly granted optional permissions can access functionality they are no longer entitled to due to missing permission verification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-4gh2-m88h-8cj8

## What is CVE-2023-41939?

CVE-2023-41939 is a high-severity missing authorization vulnerability in Jenkins SSH2 Easy Plugin, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins SSH2 Easy Plugin 1.4 and earlier does not verify that permissions configured to be granted are enabled, potentially allowing users formerly granted (typically optional permissions, like Overall/Manage) to access functionality they're no longer entitled to.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2023-41939?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ssh2easy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ssh2easy` | Maven | All versions | 1.6 |
| `org.jenkins-ci.plugins:ssh2easy` | Maven | All versions | 1.6 |

Products: Jenkins Ssh2 Easy.

## How do I fix CVE-2023-41939?

Upgrade org.jenkins-ci.plugins:ssh2easy to 1.6 or later.

## Is CVE-2023-41939 being exploited?

There is no known exploitation of CVE-2023-41939 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41939 and fix it if it is affected.

What it is: CVE-2023-41939 is a high-severity missing authorization vulnerability in Jenkins SSH2 Easy Plugin, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-41939 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ssh2easy (Maven): affected all versions; fixed in 1.6
- org.jenkins-ci.plugins:ssh2easy (Maven): affected all versions; fixed in 1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41939/ (Markdown: https://insights.sbomify.com/CVE-2023-41939/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41939
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41939
- OSV: https://osv.dev/vulnerability/CVE-2023-41939

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41939/
Summaries are generated and may contain mistakes; the official description above is the record.
