CVE-2023-4197 Dolibarr ERP CRM (<= 18.0.1) Improper Input Sanitization Authenticated RCE

High 7.5 Published Updated

Authenticated attackers can inject and execute arbitrary PHP code via improper input validation in the website creation feature.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-4197?

CVE-2023-4197 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 1 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.

Weakness: CWE-74, CWE-20

Which versions are affected by CVE-2023-4197?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.

PackageAffectedFixed in
dolibarr/dolibarr PackagistAll versions18.0.2
dolibarr/dolibarr PackagistAll versions18.0.2
dolibarr BitnamiAll versions to 18.0.1None

Products include Dolibarr Dolibarr Erp\/Crm.

How do I fix CVE-2023-4197?

Upgrade dolibarr/dolibarr to 18.0.2 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-4197 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4197 exists.

Public exploit code: 1 proofs of concept on GitHub.

All Dolibarr Dolibarr Erp\/Crm vulnerabilities

Sources

Also known as BIT-dolibarr-2023-4197, GHSA-r9cm-pw9j-3fpx, UBUNTU-CVE-2023-4197.

Is CVE-2023-4197 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free