{"answers":{"affected":"3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4197 exists.","fix":"Upgrade dolibarr/dolibarr to 18.0.2 or later.","what":"CVE-2023-4197 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 1 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-4197 and fix it if it is affected.\n\nWhat it is: CVE-2023-4197 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 1 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-4197 exists.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 18.0.2\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 18.0.2\n- dolibarr (Bitnami): affected all versions up to 18.0.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-4197/ (Markdown: https://insights.sbomify.com/CVE-2023-4197/index.md)","id":"CVE-2023-4197","markdown":"https://insights.sbomify.com/CVE-2023-4197/index.md","name":"CVE-2023-4197","record":{"aliases":["BIT-dolibarr-2023-4197","GHSA-r9cm-pw9j-3fpx","UBUNTU-CVE-2023-4197"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP CRM","requires_auth":"low_privilege","summary":"Authenticated attackers can inject and execute arbitrary PHP code via improper input validation in the website creation feature.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"STAR_Labs","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper input validation in Dolibarr ERP CRM \u003c= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2024-05-25","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-05-25T23:45:30Z","kind":"github_poc","ref":"https://github.com/alienkeric/CVE-2023-4197","stars":0,"title":"this is a simple script from CVE-2023-4197 that was little bit modified since because it didn't work at first time with broadlight machine from HTB which means that we have to modify the script a little bit and then use it as how the ducumentation says"}],"tier":"weaponised"},"has_fix":true,"headline":"Dolibarr ERP CRM (\u003c= 18.0.1) Improper Input Sanitization Authenticated RCE","id":"CVE-2023-4197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"code_injection","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Dolibarr ERP CRM (\u003c= 17.0.3) Improper Access Control","id":"CVE-2023-4198"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["0"],"last_affected":["18.0.1"],"package":"dolibarr","purl":"pkg:bitnami/dolibarr","source":"BIT-dolibarr-2023-4197"},{"ecosystem":"Packagist","fixed":["18.0.2"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-r9cm-pw9j-3fpx"},{"ecosystem":"Packagist","fixed":["18.0.2"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-r9cm-pw9j-3fpx"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in cockpit-hq/cockpit","id":"CVE-2023-4196"},"products":["Dolibarr ERP CRM"],"published":"2023-11-01","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-05","vendors":["Dolibarr"]},"summary":"Authenticated attackers can inject and execute arbitrary PHP code via improper input validation in the website creation feature.","url":"https://insights.sbomify.com/CVE-2023-4197/"}