# CVE-2023-41993: Apple Multiple Products WebKit Code Execution

> Processing web content may lead to arbitrary code execution on Apple operating systems, requiring an upgrade to patched versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Sep 2023 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-java-2023-41993, BIT-java-min-2023-41993, BIT-jre-2023-41993, DEBIAN-CVE-2023-41993, GHSA-2hcr-79rm-r8rp, MINI-3h36-vhvm-7885, MINI-7pfc-fppm-j52j, MINI-c954-5277-gh5j, MINI-cmcv-mwrm-8829, MINI-f2vw-ggfx-x8g6, MINI-gh8p-62hx-93r5, MINI-hm49-pggr-x376, MINI-p677-cm3w-3fwh, UBUNTU-CVE-2023-41993

## What is CVE-2023-41993?

CVE-2023-41993 is a high-severity memory corruption vulnerability in Apple Ipados, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The issue was addressed with improved checks. This issue is fixed in macOS Sonoma 14. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS before iOS 16.7.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2023-41993?

3 open source packages ship an affected version, including java, java-min and jre. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.411 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.411 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.411 |

Products: Apple Ipados, Apple Iphone Os, Apple Macos, Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Cloud Insights Acquisition Unit, Netapp Cloud Insights Storage Workload Security Agent, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Oracle Graalvm, Oracle Jdk, Oracle Jre, Webkitgtk Webkitgtk\+.

## How do I fix CVE-2023-41993?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.411. US federal agencies must fix it by 16 Oct 2023.

## Is CVE-2023-41993 being exploited?

Yes. Attackers have exploited CVE-2023-41993 in the wild since at least 25 Sep 2023.

Public exploit code:

- https://github.com/po6ix/POC-for-CVE-2023-41993 (github_poc): https://github.com/po6ix/POC-for-CVE-2023-41993
- testing poc (github_poc): https://github.com/hrtowii/cve-2023-41993-test
- CVE-2023-41993 (github_poc): https://github.com/0x06060606/CVE-2023-41993
- https://github.com/J3Ss0u/CVE-2023-41993 (github_poc): https://github.com/J3Ss0u/CVE-2023-41993
- JSC DFG CSE offset-key bug, GetterSetter leak - PoC + exploit (github_poc): https://github.com/jamezx32/CVE-2023-41993

## Other vulnerabilities in Apple Ipados

- [CVE-2025-43300](https://insights.sbomify.com/CVE-2025-43300/): Apple iOS, iPadOS, and macOS Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24201](https://insights.sbomify.com/CVE-2025-24201/): Apple Multiple Products WebKit Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24085](https://insights.sbomify.com/CVE-2025-24085/): Apple Multiple Products Use-After-Free (critical 10.0, exploited in the wild)
- [CVE-2025-31200](https://insights.sbomify.com/CVE-2025-31200/): Apple Multiple Products Memory Corruption (critical 9.8, exploited in the wild)
- [CVE-2025-31201](https://insights.sbomify.com/CVE-2025-31201/): Apple Multiple Products Arbitrary Read and Write (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-41993 and fix it if it is affected.

What it is: CVE-2023-41993 is a high-severity memory corruption vulnerability in Apple Ipados, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2023-41993 in the wild since at least 25 Sep 2023.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.411

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-41993/ (Markdown: https://insights.sbomify.com/CVE-2023-41993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-41993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-41993
- OSV: https://osv.dev/vulnerability/CVE-2023-41993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-41993/
Summaries are generated and may contain mistakes; the official description above is the record.
