# CVE-2023-42261: Withdrawn Advisory: Mobile Security Framework (MobSF) Vulnerable to Insecure Permissions

> Attackers can access MobSF without authentication if deployed on untrusted networks, requiring reverse proxy mitigation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-cc8j-6phr-jv9x, PYSEC-2023-310

## What is CVE-2023-42261?

CVE-2023-42261 is a high-severity missing authorization vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mobile Security Framework (MobSF) <=v3.7.8 Beta is vulnerable to Insecure Permissions. NOTE: the vendor's position is that authentication is intentionally not implemented because the product is not intended for an untrusted network environment. Use cases requiring authentication could, for example, use a reverse proxy server.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2023-42261?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 3.9.7 |
| `mobsf` | PyPI | All versions | 3.9.7 |
| `mobsf` | PyPI | All versions | 3.9.7 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2023-42261?

Upgrade mobsf to 3.9.7 or later.

## Is CVE-2023-42261 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42261 exists.

## Other vulnerabilities in n/a

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42261 and fix it if it is affected.

What it is: CVE-2023-42261 is a high-severity missing authorization vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42261 exists.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 3.9.7
- mobsf (PyPI): affected all versions; fixed in 3.9.7
- mobsf (PyPI): affected all versions; fixed in 3.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42261/ (Markdown: https://insights.sbomify.com/CVE-2023-42261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42261
- OSV: https://osv.dev/vulnerability/CVE-2023-42261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42261/
Summaries are generated and may contain mistakes; the official description above is the record.
