# CVE-2023-42278: hutool Buffer Overflow vulnerability

> A buffer overflow in Hutool's JSON parsing allows attackers to execute arbitrary code or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-rr66-qh5m-w6mx

## What is CVE-2023-42278?

CVE-2023-42278 is a high-severity memory corruption vulnerability in n/a, published on 8 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hutool v5.8.21 was discovered to contain a buffer overflow via the component JSONUtil.parse().

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2023-42278?

4 open source packages ship an affected version, including cn.hutool:hutool-core and cn.hutool:hutool-json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cn.hutool:hutool-core` | Maven | All versions | 5.8.22 |
| `cn.hutool:hutool-core` | Maven | All versions | 5.8.22 |
| `cn.hutool:hutool-json` | Maven | All versions | 5.8.22 |
| `cn.hutool:hutool-json` | Maven | All versions | 5.8.22 |

Products: Hutool Hutool.

## How do I fix CVE-2023-42278?

Upgrade cn.hutool:hutool-core to 5.8.22 or later.

## Is CVE-2023-42278 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42278 exists.

## Other vulnerabilities in n/a

- [CVE-2023-42276](https://insights.sbomify.com/CVE-2023-42276/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-42277](https://insights.sbomify.com/CVE-2023-42277/): hutool Buffer Overflow vulnerability (critical 9.8)
- [CVE-2023-24162](https://insights.sbomify.com/CVE-2023-24162/): Dromara Hutool Deserialization of Untrusted Data vulnerability (critical 9.8)
- [CVE-2023-24163](https://insights.sbomify.com/CVE-2023-24163/): Dromara hutool vulnerable to SQL Injection (critical 9.8)
- [CVE-2022-22885](https://insights.sbomify.com/CVE-2022-22885/): Improper Certificate Validation in Hutool (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42278 and fix it if it is affected.

What it is: CVE-2023-42278 is a high-severity memory corruption vulnerability in n/a, published on 8 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42278 exists.

Affected packages and fixed versions:
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 5.8.22
- cn.hutool:hutool-core (Maven): affected all versions; fixed in 5.8.22
- cn.hutool:hutool-json (Maven): affected all versions; fixed in 5.8.22
- cn.hutool:hutool-json (Maven): affected all versions; fixed in 5.8.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42278/ (Markdown: https://insights.sbomify.com/CVE-2023-42278/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42278
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42278
- OSV: https://osv.dev/vulnerability/CVE-2023-42278

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42278/
Summaries are generated and may contain mistakes; the official description above is the record.
