{"answers":{"affected":"4 open source packages ship an affected version, including ip. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42282 exists.","fix":"Upgrade ip to a fixed version for your release line: 1.1.9 or 2.0.1.","what":"CVE-2023-42282 is a critical server-side request forgery vulnerability in n/a, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-42282 and fix it if it is affected.\n\nWhat it is: CVE-2023-42282 is a critical server-side request forgery vulnerability in n/a, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42282 exists.\n\nAffected packages and fixed versions:\n- ip (npm): affected all versions; fixed in 1.1.9\n- ip (npm): affected all versions; fixed in 1.1.9\n- ip (npm): affected from 2.0.0; fixed in 2.0.1\n- ip (npm): affected from 2.0.0; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42282/ (Markdown: https://insights.sbomify.com/CVE-2023-42282/index.md)","id":"CVE-2023-42282","markdown":"https://insights.sbomify.com/CVE-2023-42282/index.md","name":"CVE-2023-42282","record":{"aliases":["AZL-34379","AZL-34380","AZL-34439","AZL-35042","CLSA-2026-1774657398","CLSA-2026-1774657399","DEBIAN-CVE-2023-42282","GHSA-78xj-cgh5-2h22","MINI-fr98-8537-5hj6","ROOT-APP-NPM-CVE-2023-42282","UBUNTU-CVE-2023-42282","USN-6643-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js IP library","requires_auth":"none","summary":"An attacker can bypass IP validation checks in the Node.js ip package to perform Server-Side Request Forgery attacks.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ip","vendor":"fedorindutny"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally routable via isPublic.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NPM IP package incorrectly identifies some private IP addresses as public","id":"CVE-2023-42282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":4,"n_references":5,"next":{"headline":"SQL injection in n/a","id":"CVE-2023-42283"},"packages":[{"ecosystem":"npm","fixed":["1.1.9"],"introduced":["0"],"last_affected":[],"package":"ip","purl":null,"source":"GHSA-78xj-cgh5-2h22"},{"ecosystem":"npm","fixed":["1.1.9"],"introduced":["0"],"last_affected":[],"package":"ip","purl":"pkg:npm/ip","source":"GHSA-78xj-cgh5-2h22"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"ip","purl":null,"source":"GHSA-78xj-cgh5-2h22"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"ip","purl":"pkg:npm/ip","source":"GHSA-78xj-cgh5-2h22"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2023-42280"},"products":["n/a"],"published":"2024-02-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-15","vendors":["n/a"]},"summary":"An attacker can bypass IP validation checks in the Node.js ip package to perform Server-Side Request Forgery attacks.","url":"https://insights.sbomify.com/CVE-2023-42282/"}