# CVE-2023-42343: Alkacon OpenCms is vulnerable to XSS via cmis-online/type

> Attackers can inject malicious scripts into OpenCms via the cmis-online/type parameter, potentially compromising user sessions or executing code.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-8gpv-c454-3hfc

## What is CVE-2023-42343?

CVE-2023-42343 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross Site Scripting vulnerability in Alkacon OpenCms before 10.5.1 exists via cmis-online/type.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-42343?

2 open source packages ship an affected version, including org.opencms:opencms-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |

## How do I fix CVE-2023-42343?

Upgrade org.opencms:opencms-core to 16.0 or later.

## Is CVE-2023-42343 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42343 exists.

Public exploit code:

- OpenCMS - Cross-Site Scripting (nuclei): http/cves/2023/CVE-2023-42343.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42343 and fix it if it is affected.

What it is: CVE-2023-42343 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42343 exists.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42343/ (Markdown: https://insights.sbomify.com/CVE-2023-42343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42343
- OSV: https://osv.dev/vulnerability/CVE-2023-42343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42343/
Summaries are generated and may contain mistakes; the official description above is the record.
