{"answers":{"affected":"2 open source packages ship an affected version, including org.opencms:opencms-core.","exploited":"There is no known exploitation of CVE-2023-42345 in the wild and no public exploit code.","fix":"Upgrade org.opencms:opencms-core to 16.0 or later.","what":"CVE-2023-42345 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-42345 and fix it if it is affected.\n\nWhat it is: CVE-2023-42345 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-42345 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42345/ (Markdown: https://insights.sbomify.com/CVE-2023-42345/index.md)","id":"CVE-2023-42345","markdown":"https://insights.sbomify.com/CVE-2023-42345/index.md","name":"CVE-2023-42345","record":{"aliases":["GHSA-2887-f3v6-6rjf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCms CMS","requires_auth":"none","summary":"Cross-site scripting in OpenCms allows attackers to inject malicious scripts via updateModelGroups.jsp, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Cross Site Scripting vulnerability in Alkacon OpenCms before 16 exists via updateModelGroups.jsp.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Alkacon OpenCms is vulnerable to XSS via updateModelGroups.jsp","id":"CVE-2023-42345","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Alkacon OpenCms is vulnerable to XXE when the \u003c!DOCTYPE\u003e refers to an external host","id":"CVE-2023-42346"},"packages":[{"ecosystem":"Maven","fixed":["16.0"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":null,"source":"GHSA-2887-f3v6-6rjf"},{"ecosystem":"Maven","fixed":["16.0"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":"pkg:maven/org.opencms/opencms-core","source":"GHSA-2887-f3v6-6rjf"}],"prev":{"headline":"Alkacon OpenCms allows remote unauthenticated attackers to obtain sensitive information","id":"CVE-2023-42344"},"products":["n/a"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["n/a"]},"summary":"Cross-site scripting in OpenCms allows attackers to inject malicious scripts via updateModelGroups.jsp, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2023-42345/"}