# CVE-2023-42345: Alkacon OpenCms is vulnerable to XSS via updateModelGroups.jsp

> Cross-site scripting in OpenCms allows attackers to inject malicious scripts via updateModelGroups.jsp, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-2887-f3v6-6rjf

## What is CVE-2023-42345?

CVE-2023-42345 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross Site Scripting vulnerability in Alkacon OpenCms before 16 exists via updateModelGroups.jsp.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-42345?

2 open source packages ship an affected version, including org.opencms:opencms-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |

## How do I fix CVE-2023-42345?

Upgrade org.opencms:opencms-core to 16.0 or later.

## Is CVE-2023-42345 being exploited?

There is no known exploitation of CVE-2023-42345 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42345 and fix it if it is affected.

What it is: CVE-2023-42345 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-42345 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42345/ (Markdown: https://insights.sbomify.com/CVE-2023-42345/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42345
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42345
- OSV: https://osv.dev/vulnerability/CVE-2023-42345

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42345/
Summaries are generated and may contain mistakes; the official description above is the record.
