{"answers":{"affected":"2 open source packages ship an affected version, including org.opencms:opencms-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42346 exists.","fix":"Upgrade org.opencms:opencms-core to 16.0 or later.","what":"CVE-2023-42346 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-42346 and fix it if it is affected.\n\nWhat it is: CVE-2023-42346 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42346 exists.\n\nAffected packages and fixed versions:\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42346/ (Markdown: https://insights.sbomify.com/CVE-2023-42346/index.md)","id":"CVE-2023-42346","markdown":"https://insights.sbomify.com/CVE-2023-42346/index.md","name":"CVE-2023-42346","record":{"aliases":["GHSA-pj6p-9p8x-5mfc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCms","requires_auth":"none","summary":"An attacker can exploit an XML External Entity vulnerability in OpenCms to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Alkacon OpenCms before 16 allows XXE when the \u003c!DOCTYPE\u003e refers to an external host.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Alkacon OpenCms is vulnerable to XXE when the \u003c!DOCTYPE\u003e refers to an external host","id":"CVE-2023-42346","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2023-42358"},"packages":[{"ecosystem":"Maven","fixed":["16.0"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":null,"source":"GHSA-pj6p-9p8x-5mfc"},{"ecosystem":"Maven","fixed":["16.0"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":"pkg:maven/org.opencms/opencms-core","source":"GHSA-pj6p-9p8x-5mfc"}],"prev":{"headline":"Alkacon OpenCms is vulnerable to XSS via updateModelGroups.jsp","id":"CVE-2023-42345"},"products":["n/a"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["n/a"]},"summary":"An attacker can exploit an XML External Entity vulnerability in OpenCms to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2023-42346/"}