# CVE-2023-42346: Alkacon OpenCms is vulnerable to XXE when the <!DOCTYPE> refers to an external host

> An attacker can exploit an XML External Entity vulnerability in OpenCms to read sensitive data or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-pj6p-9p8x-5mfc

## What is CVE-2023-42346?

CVE-2023-42346 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Alkacon OpenCms before 16 allows XXE when the <!DOCTYPE> refers to an external host.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-42346?

2 open source packages ship an affected version, including org.opencms:opencms-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |
| `org.opencms:opencms-core` | Maven | All versions | 16.0 |

## How do I fix CVE-2023-42346?

Upgrade org.opencms:opencms-core to 16.0 or later.

## Is CVE-2023-42346 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42346 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42346 and fix it if it is affected.

What it is: CVE-2023-42346 is a high-severity vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-42346 exists.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0
- org.opencms:opencms-core (Maven): affected all versions; fixed in 16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42346/ (Markdown: https://insights.sbomify.com/CVE-2023-42346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42346
- OSV: https://osv.dev/vulnerability/CVE-2023-42346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42346/
Summaries are generated and may contain mistakes; the official description above is the record.
