# CVE-2023-4241: lol-html panics on certain HTML inputs

> Attackers can cause a denial of service by providing specific HTML inputs to the lol-html library, affecting applications processing untrusted HTML.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-c3x7-354f-4p2x

## What is CVE-2023-4241?

CVE-2023-4241 is a high-severity denial of service vulnerability in Cloudflare lol-html, published on 16 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lol-html can cause panics on certain HTML inputs. Anyone processing arbitrary 3rd party HTML with the library is affected.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-4241?

2 open source packages ship an affected version, including lol-html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lol-html` | crates.io | All versions | 1.1.1 |
| `lol-html` | crates.io | All versions | 1.1.1 |

Products: Cloudflare Lol-Html.

## How do I fix CVE-2023-4241?

Upgrade lol-html to 1.1.1 or later.

## Is CVE-2023-4241 being exploited?

There is no known exploitation of CVE-2023-4241 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-4241 and fix it if it is affected.

What it is: CVE-2023-4241 is a high-severity denial of service vulnerability in Cloudflare lol-html, published on 16 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-4241 in the wild and no public exploit code.

Affected packages and fixed versions:
- lol-html (crates.io): affected all versions; fixed in 1.1.1
- lol-html (crates.io): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-4241/ (Markdown: https://insights.sbomify.com/CVE-2023-4241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-4241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-4241
- OSV: https://osv.dev/vulnerability/CVE-2023-4241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-4241/
Summaries are generated and may contain mistakes; the official description above is the record.
