# CVE-2023-42443: Vyper vulnerable to memory corruption in certain builtins utilizing `msize`

> Attackers can corrupt memory in Vyper smart contracts using specific builtins, potentially leading to incorrect bytecode deployment or call data manipulation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-c647-pxm2-c52w, PYSEC-2023-306

## What is CVE-2023-42443?

CVE-2023-42443 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 18 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). In version 0.3.9 and prior, under certain conditions, the memory used by the builtins `raw_call`, `create_from_blueprint` and `create_copy_of` can be corrupted. For `raw_call`, the argument buffer of the call can be corrupted, leading to incorrect `calldata` in the sub-context. For `create_from_blueprint` and `create_copy_of`, the buffer for the to-be-deployed bytecode can be corrupted, leading to deploying incorrect bytecode.

Each builtin has conditions that must be fulfilled for the corruption to happen. For `raw_call`, the `data` argument of the builtin must be `msg.data` and the `value` or `gas` passed to the builtin must be some complex expression that results in writing to the memory. For `create_copy_of`, the `value` or `salt` passed to the builtin must be some complex expression that results in writing to the memory. For `create_from_blueprint`, either no constructor parameters should be passed to the builtin or `raw_args` should be set to True, and the `value` or `salt` passed to the builtin must be some complex expression that results in writing to the memory.

As of time of publication, no patched version exists. The issue is still being investigated, and there might be other cases where the corruption might happen. When the builtin is being called from an `internal` function `F`, the issue is not present provided that the function calling `F` wrote to memory before calling `F`. As a workaround, the complex expressions that are being passed as kwargs to the builtin should be cached in memory prior to the call to the builtin.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-42443?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.10 |
| `vyper` | PyPI | From 0.3.4 | 0.3.10 |
| `vyper` | PyPI | From 0.3.4 | 0.3.10 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-42443?

Upgrade vyper to 0.3.10 or later.

## Is CVE-2023-42443 being exploited?

There is no known exploitation of CVE-2023-42443 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42443 and fix it if it is affected.

What it is: CVE-2023-42443 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 18 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42443 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.10
- vyper (PyPI): affected from 0.3.4; fixed in 0.3.10
- vyper (PyPI): affected from 0.3.4; fixed in 0.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42443/ (Markdown: https://insights.sbomify.com/CVE-2023-42443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42443
- OSV: https://osv.dev/vulnerability/CVE-2023-42443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42443/
Summaries are generated and may contain mistakes; the official description above is the record.
