{"answers":{"affected":"2 open source packages ship an affected version, including pow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-42446 in the wild and no public exploit code.","fix":"Upgrade pow to 1.0.34 or later.","what":"CVE-2023-42446 is a medium-severity authentication bypass vulnerability in pow-auth pow, published on 18 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-42446 and fix it if it is affected.\n\nWhat it is: CVE-2023-42446 is a medium-severity authentication bypass vulnerability in pow-auth pow, published on 18 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-42446 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pow (Hex): affected from 1.0.14; fixed in 1.0.34\n- pow (Hex): affected from 1.0.14; fixed in 1.0.34\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42446/ (Markdown: https://insights.sbomify.com/CVE-2023-42446/index.md)","id":"CVE-2023-42446","markdown":"https://insights.sbomify.com/CVE-2023-42446/index.md","name":"CVE-2023-42446","record":{"aliases":["GHSA-3cjh-p6pw-jhv9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Elixir authentication library","requires_auth":"low_privilege","summary":"Attackers can hijack sessions if the Mnesia cache backend is used and instances are shut down longer than the session TTL.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pow","vendor":"powauth"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-672","name":"Operation on a Resource after Expiration or Release"},{"id":"CWE-298","name":"Improper Validation of Certificate Expiration"}],"description":"Pow is a authentication and user management solution for Phoenix and Plug-based apps. Starting in version 1.0.14 and prior to version 1.0.34, use of `Pow.Store.Backend.MnesiaCache` is susceptible to session hijacking as expired keys are not being invalidated correctly on startup. A session may expire when all `Pow.Store.Backend.MnesiaCache` instances have been shut down for a period that is longer than a session's remaining TTL. Version 1.0.34 contains a patch for this issue. As a workaround, expired keys, including all expired sessions, can be manually invalidated.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pow Mnesia cache doesn't invalidate all expired keys on startup","id":"CVE-2023-42446","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"blurhash panics on parsing crafted inputs","id":"CVE-2023-42447"},"packages":[{"ecosystem":"Hex","fixed":["1.0.34"],"introduced":["1.0.14"],"last_affected":[],"package":"pow","purl":null,"source":"GHSA-3cjh-p6pw-jhv9"},{"ecosystem":"Hex","fixed":["1.0.34"],"introduced":["1.0.14"],"last_affected":[],"package":"pow","purl":"pkg:hex/pow","source":"GHSA-3cjh-p6pw-jhv9"}],"prev":{"headline":"Possible local file exfiltration by XML External entity injection","id":"CVE-2023-42445"},"products":["pow"],"published":"2023-09-18","related":[{"cvss_score":6.5,"headline":"Session fixation attack in Pow (Hex package)","id":"CVE-2020-5205","kev_date_added":null,"published":"2020-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["pow-auth"]},"summary":"Attackers can hijack sessions if the Mnesia cache backend is used and instances are shut down longer than the session TTL.","url":"https://insights.sbomify.com/CVE-2023-42446/"}