# CVE-2023-42446: Pow Mnesia cache doesn't invalidate all expired keys on startup

> Attackers can hijack sessions if the Mnesia cache backend is used and instances are shut down longer than the session TTL.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-3cjh-p6pw-jhv9

## What is CVE-2023-42446?

CVE-2023-42446 is a medium-severity authentication bypass vulnerability in pow-auth pow, published on 18 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pow is a authentication and user management solution for Phoenix and Plug-based apps. Starting in version 1.0.14 and prior to version 1.0.34, use of `Pow.Store.Backend.MnesiaCache` is susceptible to session hijacking as expired keys are not being invalidated correctly on startup. A session may expire when all `Pow.Store.Backend.MnesiaCache` instances have been shut down for a period that is longer than a session's remaining TTL. Version 1.0.34 contains a patch for this issue. As a workaround, expired keys, including all expired sessions, can be manually invalidated.

Weakness: CWE-672 (Operation on a Resource after Expiration or Release), CWE-298 (Improper Validation of Certificate Expiration)

## Which versions are affected by CVE-2023-42446?

2 open source packages ship an affected version, including pow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pow` | Hex | From 1.0.14 | 1.0.34 |
| `pow` | Hex | From 1.0.14 | 1.0.34 |

Products: Powauth Pow.

## How do I fix CVE-2023-42446?

Upgrade pow to 1.0.34 or later.

## Is CVE-2023-42446 being exploited?

There is no known exploitation of CVE-2023-42446 in the wild and no public exploit code.

## Other vulnerabilities in pow-auth pow

- [CVE-2020-5205](https://insights.sbomify.com/CVE-2020-5205/): Session fixation attack in Pow (Hex package) (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42446 and fix it if it is affected.

What it is: CVE-2023-42446 is a medium-severity authentication bypass vulnerability in pow-auth pow, published on 18 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42446 in the wild and no public exploit code.

Affected packages and fixed versions:
- pow (Hex): affected from 1.0.14; fixed in 1.0.34
- pow (Hex): affected from 1.0.14; fixed in 1.0.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42446/ (Markdown: https://insights.sbomify.com/CVE-2023-42446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42446
- OSV: https://osv.dev/vulnerability/CVE-2023-42446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42446/
Summaries are generated and may contain mistakes; the official description above is the record.
