CVE-2023-42447 blurhash panics on parsing crafted inputs
Attackers can cause a denial of service by sending crafted blurhash strings to applications using the vulnerable Rust library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-42447?
CVE-2023-42447 is a high-severity denial of service vulnerability in whisperfish blurhash-rs, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
blurhash-rs is a pure Rust implementation of Blurhash, software for encoding images into ASCII strings that can be turned into a gradient of colors representing the original image. In version 0.1.1, the blurhash parsing code may panic due to multiple panic-guarded out-of-bounds accesses on untrusted input. In a typical deployment, this may get triggered by feeding a maliciously crafted blurhashes over the network. These may include UTF-8 compliant strings containing multi-byte UTF-8 characters. A patch is available in version 0.2.0, which requires user intervention because of slight API churn. No known workarounds are available.
Which versions are affected by CVE-2023-42447?
3 open source packages ship an affected version, including blurhash. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
blurhash crates.io | From 0.0.0-0 | 0.2.0 |
blurhash crates.io | From 0.1.1 | 0.2.0 |
blurhash crates.io | From 0.1.1 | 0.2.0 |
Products include Whisperfish Blurhash-Rs.
How do I fix CVE-2023-42447?
Upgrade blurhash to 0.2.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-42447 being exploited?
There is no known exploitation of CVE-2023-42447 in the wild and no public exploit code.
Sources
Also known as GHSA-cxvp-82cq-57h2, RUSTSEC-2023-0083.