{"answers":{"affected":"3 open source packages ship an affected version, including blurhash. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-42447 in the wild and no public exploit code.","fix":"Upgrade blurhash to 0.2.0 or later.","what":"CVE-2023-42447 is a high-severity denial of service vulnerability in whisperfish blurhash-rs, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-42447 and fix it if it is affected.\n\nWhat it is: CVE-2023-42447 is a high-severity denial of service vulnerability in whisperfish blurhash-rs, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-42447 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- blurhash (crates.io): affected from 0.0.0-0; fixed in 0.2.0\n- blurhash (crates.io): affected from 0.1.1; fixed in 0.2.0\n- blurhash (crates.io): affected from 0.1.1; fixed in 0.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42447/ (Markdown: https://insights.sbomify.com/CVE-2023-42447/index.md)","id":"CVE-2023-42447","markdown":"https://insights.sbomify.com/CVE-2023-42447/index.md","name":"CVE-2023-42447","record":{"aliases":["GHSA-cxvp-82cq-57h2","RUSTSEC-2023-0083"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust blurhash library","requires_auth":"none","summary":"Attackers can cause a denial of service by sending crafted blurhash strings to applications using the vulnerable Rust library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"blurhash-rs","vendor":"whisperfish"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-392","name":"Missing Report of Error Condition"},{"id":"CWE-248","name":"Uncaught Exception"},{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"blurhash-rs is a pure Rust implementation of Blurhash, software for encoding images into ASCII strings that can be turned into a gradient of colors representing the original image. In version 0.1.1, the blurhash parsing code may panic due to multiple panic-guarded out-of-bounds accesses on untrusted input. In a typical deployment, this may get triggered by feeding a maliciously crafted blurhashes over the network. These may include UTF-8 compliant strings containing multi-byte UTF-8 characters. A patch is available in version 0.2.0, which requires user intervention because of slight API churn. No known workarounds are available.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"blurhash panics on parsing crafted inputs","id":"CVE-2023-42447","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"Business logic in hydra","id":"CVE-2023-42448"},"packages":[{"ecosystem":"crates.io","fixed":["0.2.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"blurhash","purl":"pkg:cargo/blurhash","source":"RUSTSEC-2023-0083"},{"ecosystem":"crates.io","fixed":["0.2.0"],"introduced":["0.1.1"],"last_affected":[],"package":"blurhash","purl":null,"source":"GHSA-cxvp-82cq-57h2"},{"ecosystem":"crates.io","fixed":["0.2.0"],"introduced":["0.1.1"],"last_affected":[],"package":"blurhash","purl":"pkg:cargo/blurhash","source":"GHSA-cxvp-82cq-57h2"}],"prev":{"headline":"Pow Mnesia cache doesn't invalidate all expired keys on startup","id":"CVE-2023-42446"},"products":["blurhash-rs"],"published":"2023-09-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["whisperfish"]},"summary":"Attackers can cause a denial of service by sending crafted blurhash strings to applications using the vulnerable Rust library.","url":"https://insights.sbomify.com/CVE-2023-42447/"}