# CVE-2023-42447: blurhash panics on parsing crafted inputs

> Attackers can cause a denial of service by sending crafted blurhash strings to applications using the vulnerable Rust library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-cxvp-82cq-57h2, RUSTSEC-2023-0083

## What is CVE-2023-42447?

CVE-2023-42447 is a high-severity denial of service vulnerability in whisperfish blurhash-rs, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

blurhash-rs is a pure Rust implementation of Blurhash, software for encoding images into ASCII strings that can be turned into a gradient of colors representing the original image. In version 0.1.1, the blurhash parsing code may panic due to multiple panic-guarded out-of-bounds accesses on untrusted input. In a typical deployment, this may get triggered by feeding a maliciously crafted blurhashes over the network. These may include UTF-8 compliant strings containing multi-byte UTF-8 characters. A patch is available in version 0.2.0, which requires user intervention because of slight API churn. No known workarounds are available.

Weakness: CWE-392 (Missing Report of Error Condition), CWE-248 (Uncaught Exception), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2023-42447?

3 open source packages ship an affected version, including blurhash. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blurhash` | crates.io | From 0.0.0-0 | 0.2.0 |
| `blurhash` | crates.io | From 0.1.1 | 0.2.0 |
| `blurhash` | crates.io | From 0.1.1 | 0.2.0 |

Products: Whisperfish Blurhash-Rs.

## How do I fix CVE-2023-42447?

Upgrade blurhash to 0.2.0 or later.

## Is CVE-2023-42447 being exploited?

There is no known exploitation of CVE-2023-42447 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42447 and fix it if it is affected.

What it is: CVE-2023-42447 is a high-severity denial of service vulnerability in whisperfish blurhash-rs, published on 19 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42447 in the wild and no public exploit code.

Affected packages and fixed versions:
- blurhash (crates.io): affected from 0.0.0-0; fixed in 0.2.0
- blurhash (crates.io): affected from 0.1.1; fixed in 0.2.0
- blurhash (crates.io): affected from 0.1.1; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42447/ (Markdown: https://insights.sbomify.com/CVE-2023-42447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42447
- OSV: https://osv.dev/vulnerability/CVE-2023-42447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42447/
Summaries are generated and may contain mistakes; the official description above is the record.
