{"answers":{"affected":"5 open source packages ship an affected version, including plone.rest and plone-rest. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-42457 in the wild and no public exploit code.","fix":"Upgrade plone.rest to a fixed version for your release line: 2.0.1 or 3.0.1.","what":"CVE-2023-42457 is a high-severity denial of service vulnerability in plone.rest, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-42457 and fix it if it is affected.\n\nWhat it is: CVE-2023-42457 is a high-severity denial of service vulnerability in plone.rest, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-42457 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plone.rest (PyPI): affected from 2.0.0a1; fixed in 2.0.1\n- plone.rest (PyPI): affected from 3.0.0; fixed in 3.0.1\n- plone-rest (PyPI): affected all versions; no fix listed\n- plone-rest (PyPI): affected from 2.0.0a1; fixed in 2.0.1\n- plone-rest (PyPI): affected from 3.0.0; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42457/ (Markdown: https://insights.sbomify.com/CVE-2023-42457/index.md)","id":"CVE-2023-42457","markdown":"https://insights.sbomify.com/CVE-2023-42457/index.md","name":"CVE-2023-42457","record":{"aliases":["GHSA-h6rp-mprm-xgcq","PYSEC-2023-178"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Plone REST library","requires_auth":"none","summary":"Repeated use of the ++api++ traverser in URLs causes excessive processing time, leading to server unresponsiveness in plone.rest.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rest","vendor":"plone"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"plone.rest allows users to use HTTP verbs such as GET, POST, PUT, DELETE, etc. in Plone. Starting in the 2.x branch and prior to versions 2.0.1 and 3.0.1, when the `++api++` traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive. Patches are available in `plone.rest` 2.0.1 and 3.0.1.  Series 1.x is not affected. As a workaround, one may redirect `/++api++/++api++` to `/++api++` in one's frontend web server (nginx, Apache).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"plone.rest vulnerable to Denial of Service when ++api++ is used many times","id":"CVE-2023-42457","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":5,"n_references":4,"next":{"headline":"Zope vulnerable to Stored Cross Site Scripting with SVG images","id":"CVE-2023-42458"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":[],"package":"plone-rest","purl":"pkg:pypi/plone-rest","source":"PYSEC-2023-178"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["2.0.0a1"],"last_affected":[],"package":"plone-rest","purl":"pkg:pypi/plone-rest","source":"GHSA-h6rp-mprm-xgcq"},{"ecosystem":"PyPI","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"plone-rest","purl":"pkg:pypi/plone-rest","source":"GHSA-h6rp-mprm-xgcq"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["2.0.0a1"],"last_affected":[],"package":"plone.rest","purl":null,"source":"GHSA-h6rp-mprm-xgcq"},{"ecosystem":"PyPI","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"plone.rest","purl":null,"source":"GHSA-h6rp-mprm-xgcq"}],"prev":{"headline":"sudo-rs Session File Relative Path Traversal vulnerability","id":"CVE-2023-42456"},"products":["plone.rest"],"published":"2023-09-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["plone"]},"summary":"Repeated use of the ++api++ traverser in URLs causes excessive processing time, leading to server unresponsiveness in plone.rest.","url":"https://insights.sbomify.com/CVE-2023-42457/"}