# CVE-2023-42457: plone.rest vulnerable to Denial of Service when ++api++ is used many times

> Repeated use of the ++api++ traverser in URLs causes excessive processing time, leading to server unresponsiveness in plone.rest.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-h6rp-mprm-xgcq, PYSEC-2023-178

## What is CVE-2023-42457?

CVE-2023-42457 is a high-severity denial of service vulnerability in plone.rest, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

plone.rest allows users to use HTTP verbs such as GET, POST, PUT, DELETE, etc. in Plone. Starting in the 2.x branch and prior to versions 2.0.1 and 3.0.1, when the `++api++` traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive. Patches are available in `plone.rest` 2.0.1 and 3.0.1.  Series 1.x is not affected. As a workaround, one may redirect `/++api++/++api++` to `/++api++` in one's frontend web server (nginx, Apache).

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-42457?

5 open source packages ship an affected version, including plone.rest and plone-rest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone.rest` | PyPI | From 2.0.0a1 | 2.0.1 |
| `plone.rest` | PyPI | From 3.0.0 | 3.0.1 |
| `plone-rest` | PyPI | All versions | None |
| `plone-rest` | PyPI | From 2.0.0a1 | 2.0.1 |
| `plone-rest` | PyPI | From 3.0.0 | 3.0.1 |

Products: Plone Rest.

## How do I fix CVE-2023-42457?

Upgrade plone.rest to a fixed version for your release line: 2.0.1 or 3.0.1.

## Is CVE-2023-42457 being exploited?

There is no known exploitation of CVE-2023-42457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42457 and fix it if it is affected.

What it is: CVE-2023-42457 is a high-severity denial of service vulnerability in plone.rest, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42457 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone.rest (PyPI): affected from 2.0.0a1; fixed in 2.0.1
- plone.rest (PyPI): affected from 3.0.0; fixed in 3.0.1
- plone-rest (PyPI): affected all versions; no fix listed
- plone-rest (PyPI): affected from 2.0.0a1; fixed in 2.0.1
- plone-rest (PyPI): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42457/ (Markdown: https://insights.sbomify.com/CVE-2023-42457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42457
- OSV: https://osv.dev/vulnerability/CVE-2023-42457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42457/
Summaries are generated and may contain mistakes; the official description above is the record.
