{"answers":{"affected":"5 open source packages ship an affected version, including zope and Zope. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-42458 in the wild and no public exploit code.","fix":"Upgrade zope to a fixed version for your release line: 4.8.10 or 5.8.5.","what":"CVE-2023-42458 is a low-severity cross-site scripting vulnerability in zopefoundation Zope, published on 21 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-42458 and fix it if it is affected.\n\nWhat it is: CVE-2023-42458 is a low-severity cross-site scripting vulnerability in zopefoundation Zope, published on 21 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-42458 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zope (PyPI): affected all versions; fixed in 4.8.10, 5.8.5\n- zope (PyPI): affected all versions; fixed in 4.8.10\n- zope (PyPI): affected from 5.8.0; fixed in 5.8.5\n- Zope (PyPI): affected all versions; fixed in 4.8.10\n- Zope (PyPI): affected from 5.8.0; fixed in 5.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-42458/ (Markdown: https://insights.sbomify.com/CVE-2023-42458/index.md)","id":"CVE-2023-42458","markdown":"https://insights.sbomify.com/CVE-2023-42458/index.md","name":"CVE-2023-42458","record":{"aliases":["GHSA-wm8q-9975-xh5v","PYSEC-2026-2077"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope web application server","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via uploaded SVG images, leading to code execution when users view them.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"zope","vendor":"zope"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Zope is an open-source web application server. Prior to versions 4.8.10 and 5.8.5, there is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. Patches are available in Zope 4.8.10 and 5.8.5. As a workaround, make sure the \"Add Documents, Images, and Files\" permission is only assigned to trusted roles. By default, only the Manager has this permission.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zope vulnerable to Stored Cross Site Scripting with SVG images","id":"CVE-2023-42458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":5,"n_references":4,"next":{"headline":"Malformed DATA submessage leads to bad-free error in Fast-DDS","id":"CVE-2023-42459"},"packages":[{"ecosystem":"PyPI","fixed":["4.8.10"],"introduced":["0"],"last_affected":[],"package":"Zope","purl":null,"source":"GHSA-wm8q-9975-xh5v"},{"ecosystem":"PyPI","fixed":["5.8.5"],"introduced":["5.8.0"],"last_affected":[],"package":"Zope","purl":null,"source":"GHSA-wm8q-9975-xh5v"},{"ecosystem":"PyPI","fixed":["4.8.10","5.8.5"],"introduced":["0","5.8.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"PYSEC-2026-2077"},{"ecosystem":"PyPI","fixed":["4.8.10"],"introduced":["0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-wm8q-9975-xh5v"},{"ecosystem":"PyPI","fixed":["5.8.5"],"introduced":["5.8.0"],"last_affected":[],"package":"zope","purl":"pkg:pypi/zope","source":"GHSA-wm8q-9975-xh5v"}],"prev":{"headline":"plone.rest vulnerable to Denial of Service when ++api++ is used many times","id":"CVE-2023-42457"},"products":["Zope"],"published":"2023-09-21","related":[{"cvss_score":10,"headline":"Zope DTML implementation Improper Authentication","id":"CVE-2000-0062","kev_date_added":null,"published":"2000-04-18"},{"cvss_score":8.8,"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674","kev_date_added":null,"published":"2021-06-08"},{"cvss_score":7.5,"headline":"Zope does not properly perform security registration for legacy names","id":"CVE-2000-1211","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Zope does not properly verify the access for objects with proxy roles","id":"CVE-2002-0170","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1227","kev_date_added":null,"published":"2002-06-25"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1278","kev_date_added":null,"published":"2002-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["zopefoundation"]},"summary":"Attackers can inject malicious scripts via uploaded SVG images, leading to code execution when users view them.","url":"https://insights.sbomify.com/CVE-2023-42458/"}