CVE-2023-42460 _abi_decode input not validated in complex expressions in Vyper

Medium 5.3 Published Updated

Vyper compiler fails to validate _abi_decode inputs in nested expressions, allowing bounds checking bypass and incorrect contract results.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-42460?

CVE-2023-42460 is a medium-severity vulnerability in vyperlang vyper, published on 26 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

Weakness: CWE-682

Which versions are affected by CVE-2023-42460?

3 open source packages ship an affected version, including vyper. It affects 1 product.

PackageAffectedFixed in
vyper PyPIFrom 0.3.40.3.10
vyper PyPIFrom 0.3.40.3.10
vyper PyPIFrom 0.3.40.3.10

Products include Vyperlang Vyper.

How do I fix CVE-2023-42460?

Upgrade vyper to 0.3.10 or later.

Is CVE-2023-42460 being exploited?

There is no known exploitation of CVE-2023-42460 in the wild and no public exploit code.

Sources

Also known as GHSA-cx2q-hfxr-rj97, PYSEC-2023-191.

Is CVE-2023-42460 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free