CVE-2023-42501 Apache Superset: Unnecessary read permissions within the Gamma role

Medium 4.3 Published Updated

Authenticated users can read CSS templates and annotations due to excessive read permissions in the Gamma role.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-42501?

CVE-2023-42501 is a medium-severity missing authorization vulnerability in Apache Superset, published on 27 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.

Weakness: CWE-276

Which versions are affected by CVE-2023-42501?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions2.1.2
apache-superset PyPIAll versions2.1.2
apache-superset PyPIAll versions2.1.2
superset BitnamiAll versions2.1.1

Products include Apache Superset.

How do I fix CVE-2023-42501?

Upgrade apache-superset to 2.1.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-42501 being exploited?

There is no known exploitation of CVE-2023-42501 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2023-42501, GHSA-vv65-fjfj-4736, PYSEC-2026-1188.

Is CVE-2023-42501 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free