# CVE-2023-42502: Apache Superset: Open Redirect Vulnerability

> An authenticated attacker can redirect users to malicious sites by spoofing the HTTP Host header in dataset links.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-superset-2023-42502, GHSA-hc74-9vjm-c9xv, PYSEC-2026-1182

## What is CVE-2023-42502?

CVE-2023-42502 is a medium-severity vulnerability in Apache Superset, published on 28 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

An authenticated attacker with update datasets permission could change a dataset link to an untrusted site by spoofing the HTTP Host header, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset versions before 3.0.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2023-42502?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `superset` | Bitnami | All versions | 3.0.0 |

Products: Apache Superset.

## How do I fix CVE-2023-42502?

Upgrade apache-superset to 3.0.0 or later.

## Is CVE-2023-42502 being exploited?

There is no known exploitation of CVE-2023-42502 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42502 and fix it if it is affected.

What it is: CVE-2023-42502 is a medium-severity vulnerability in Apache Superset, published on 28 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-42502 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- superset (Bitnami): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42502/ (Markdown: https://insights.sbomify.com/CVE-2023-42502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42502
- OSV: https://osv.dev/vulnerability/CVE-2023-42502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42502/
Summaries are generated and may contain mistakes; the official description above is the record.
