# CVE-2023-42503: Apache Commons Compress: Denial of service via CPU consumption for malformed TAR file

> Attackers can cause denial of service via CPU exhaustion by crafting malformed TAR files with excessive precision in time headers.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2026-RB49901, CLEANSTART-2026-UD67941, DEBIAN-CVE-2023-42503, GHSA-cgwf-w82q-5jrr, MINI-2955-hv34-2hpw, ROOT-APP-MAVEN-CVE-2023-42503, UBUNTU-CVE-2023-42503

## What is CVE-2023-42503?

CVE-2023-42503 is a medium-severity denial of service vulnerability in Apache Commons Compress, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Input Validation, Uncontrolled Resource Consumption vulnerability in Apache Commons Compress in TAR parsing.This issue affects Apache Commons Compress: from 1.22 before 1.24.0.

Users are recommended to upgrade to version 1.24.0, which fixes the issue.

A third party can create a malformed TAR file by manipulating file modification times headers, which when parsed with Apache Commons Compress, will cause a denial of service issue via CPU consumption.

In version 1.22 of Apache Commons Compress, support was added for file modification times with higher precision (issue # COMPRESS-612 [1]). The format for the PAX extended headers carrying this data consists of two numbers separated by a period [2], indicating seconds and subsecond precision (for example “1647221103.5998539”). The impacted fields are “atime”, “ctime”, “mtime” and “LIBARCHIVE.creationtime”. No input validation is performed prior to the parsing of header values.

Parsing of these numbers uses the BigDecimal [3] class from the JDK which has a publicly known algorithmic complexity issue when doing operations on large numbers, causing denial of service (see issue # JDK-6560193 [4]). A third party can manipulate file time headers in a TAR file by placing a number with a very long fraction (300,000 digits) or a number with exponent notation (such as “9e9999999”) within a file modification time header, and the parsing of files with these headers will take hours instead of seconds, leading to a denial of service via exhaustion of CPU resources. This issue is similar to CVE-2012-2098 [5].

[1]:  https://issues.apache.org/jira/browse/COMPRESS-612 
[2]:  https://pubs.opengroup.org/onlinepubs/9699919799/utilities/pax.html#tag_20_92_13_05 
[3]:  https://docs.oracle.com/javase/8/docs/api/java/math/BigDecimal.html 
[4]:  https://bugs.openjdk.org/browse/JDK-6560193 
[5]:  https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2098 

Only applications using CompressorStreamFactory class (with auto-detection of file types), TarArchiveInputStream and TarFile classes to parse TAR files are impacted. Since this code was introduced in v1.22, only that version and later versions are impacted.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-42503?

2 open source packages ship an affected version, including org.apache.commons:commons-compress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-compress` | Maven | From 1.22 | 1.24.0 |
| `org.apache.commons:commons-compress` | Maven | From 1.22 | 1.24.0 |

Products: Apache Commons Compress.

## How do I fix CVE-2023-42503?

Upgrade org.apache.commons:commons-compress to 1.24.0 or later.

## Is CVE-2023-42503 being exploited?

There is no known exploitation of CVE-2023-42503 in the wild and no public exploit code.

## Other vulnerabilities in Apache Commons Compress

- [CVE-2024-25710](https://insights.sbomify.com/CVE-2024-25710/): Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file (high 8.1)
- [CVE-2021-35515](https://insights.sbomify.com/CVE-2021-35515/): Apache Commons Compress 1.6 to 1.20 denial of service vulnerability (high 7.5)
- [CVE-2021-35516](https://insights.sbomify.com/CVE-2021-35516/): Apache Commons Compress 1.6 to 1.20 denial of service vulnerability (high 7.5)
- [CVE-2021-35517](https://insights.sbomify.com/CVE-2021-35517/): Apache Commons Compress 1.1 to 1.20 denial of service vulnerability (high 7.5)
- [CVE-2021-36090](https://insights.sbomify.com/CVE-2021-36090/): Apache Commons Compress 1.0 to 1.20 denial of service vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42503 and fix it if it is affected.

What it is: CVE-2023-42503 is a medium-severity denial of service vulnerability in Apache Commons Compress, published on 14 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-42503 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-compress (Maven): affected from 1.22; fixed in 1.24.0
- org.apache.commons:commons-compress (Maven): affected from 1.22; fixed in 1.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42503/ (Markdown: https://insights.sbomify.com/CVE-2023-42503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42503
- OSV: https://osv.dev/vulnerability/CVE-2023-42503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42503/
Summaries are generated and may contain mistakes; the official description above is the record.
