# CVE-2023-42504: Apache Superset: Lack of rate limiting allows for possible denial of service

> An authenticated user can cause denial of service by initiating multiple concurrent dashboard export requests in Apache Superset.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2023-42504, GHSA-3hp7-4qq4-v5c6, PYSEC-2026-1157

## What is CVE-2023-42504?

CVE-2023-42504 is a medium-severity denial of service vulnerability in Apache Superset, published on 28 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An authenticated malicious user could initiate multiple concurrent requests, each requesting multiple dashboard exports, leading to a possible denial of service.

This issue affects Apache Superset: before 3.0.0

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-42504?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `apache-superset` | PyPI | All versions | 3.0.0 |
| `superset` | Bitnami | All versions | 3.0.0 |

Products: Apache Superset.

## How do I fix CVE-2023-42504?

Upgrade apache-superset to 3.0.0 or later.

## Is CVE-2023-42504 being exploited?

There is no known exploitation of CVE-2023-42504 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42504 and fix it if it is affected.

What it is: CVE-2023-42504 is a medium-severity denial of service vulnerability in Apache Superset, published on 28 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42504 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- apache-superset (PyPI): affected all versions; fixed in 3.0.0
- superset (Bitnami): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42504/ (Markdown: https://insights.sbomify.com/CVE-2023-42504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42504
- OSV: https://osv.dev/vulnerability/CVE-2023-42504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42504/
Summaries are generated and may contain mistakes; the official description above is the record.
