CVE-2023-42628 Liferay Portal and Liferay DXP Vulnerable to XSS in the Wiki Widget
Remote attackers can inject arbitrary scripts into Liferay Wiki pages, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-42628?
CVE-2023-42628 is a critical cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 17 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Stored cross-site scripting (XSS) vulnerability in the Wiki widget in Liferay Portal 7.1.0 through 7.4.3.87, and Liferay DXP 7.0 fix pack 83 through 102, 7.1 fix pack 28 and earlier, 7.2 fix pack 20 and earlier, 7.3 update 33 and earlier, and 7.4 before update 88 allows remote attackers to inject arbitrary web script or HTML into a parent wiki page via a crafted payload injected into a wiki page's ‘Content’ text field.
Weakness: CWE-79
Which versions are affected by CVE-2023-42628?
13 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, liferay and com.liferay:com.liferay.wiki.web. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
com.liferay.portal:release.dxp.bom Maven | From 7.0.10.fp83 to 7.0.10.fp102 | None |
com.liferay.portal:release.dxp.bom Maven | From 7.0.10.fp83 to 7.0.10.fp102 | None |
com.liferay.portal:release.dxp.bom Maven | From 7.1.0 to 7.1.10.fp28 | None |
com.liferay.portal:release.dxp.bom Maven | From 7.1.0 to 7.1.10.fp28 | None |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 to 7.2.10.fp20 | None |
com.liferay.portal:release.dxp.bom Maven | From 7.2.0 to 7.2.10.fp20 | None |
7 more packages
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u34 |
com.liferay.portal:release.dxp.bom Maven | From 7.3.0 | 7.3.10.u34 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u88 |
com.liferay.portal:release.dxp.bom Maven | From 7.4.0 | 7.4.13.u88 |
liferay Bitnami | From 7.0.0 to 7.0.0 | None |
com.liferay:com.liferay.wiki.web Maven | All versions | 7.0.95 |
com.liferay:com.liferay.wiki.web Maven | All versions | 7.0.95 |
Products include Liferay Digital Experience Platform, Liferay Liferay Portal.
How do I fix CVE-2023-42628?
Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.3.10.u34 or 7.4.13.u88.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-42628 being exploited?
There is no known exploitation of CVE-2023-42628 in the wild and no public exploit code.
Other vulnerabilities in Liferay Digital Experience Platform
- CVE-2024-8980 Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console
- CVE-2023-42496 Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2023-42498 Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting
- CVE-2024-25147 Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting
- CVE-2024-26269 Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting
Sources
Also known as BIT-liferay-2023-42628, GHSA-hv45-r2f5-fmhj.