# CVE-2023-42792: Apache Airflow: Improper access control to DAG resources

> Authenticated users can bypass access controls to modify or clear DAG resources they do not have permission to access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-42792, GHSA-j3w8-2p2h-mrr9, PYSEC-2023-203

## What is CVE-2023-42792?

CVE-2023-42792 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 14 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow, in versions prior to 2.7.2, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't.

Users of Apache Airflow are strongly advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2023-42792?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.7.2 |
| `apache-airflow` | PyPI | All versions | 2.7.2 |
| `apache-airflow` | PyPI | All versions | 2.7.2 |
| `airflow` | Bitnami | All versions | 2.7.2 |

Products: Apache Airflow.

## How do I fix CVE-2023-42792?

Upgrade apache-airflow to 2.7.2 or later.

## Is CVE-2023-42792 being exploited?

There is no known exploitation of CVE-2023-42792 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42792 and fix it if it is affected.

What it is: CVE-2023-42792 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 14 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42792 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.7.2
- apache-airflow (PyPI): affected all versions; fixed in 2.7.2
- apache-airflow (PyPI): affected all versions; fixed in 2.7.2
- airflow (Bitnami): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42792/ (Markdown: https://insights.sbomify.com/CVE-2023-42792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42792
- OSV: https://osv.dev/vulnerability/CVE-2023-42792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42792/
Summaries are generated and may contain mistakes; the official description above is the record.
