# CVE-2023-42794: Apache Tomcat: FileUpload: DoS due to accumulation of temporary files on Windows

> An attacker can cause a denial of service by filling the disk with temporary files on Windows due to incomplete cleanup of uploaded files.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2023
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-tomcat-2023-42794, CLSA-2025-1739387851, GHSA-jm7m-8jh6-29hp

## What is CVE-2023-42794?

CVE-2023-42794 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incomplete Cleanup vulnerability in Apache Tomcat.

The internal fork of Commons FileUpload packaged with Apache Tomcat 9.0.70 through 9.0.80 and 8.5.85 through 8.5.93 included an unreleased, 
in progress refactoring that exposed a potential denial of service on 
Windows if a web application opened a stream for an uploaded file but 
failed to close the stream. The file would never be deleted from disk 
creating the possibility of an eventual denial of service due to the 
disk being full.

Other, EOL versions may also be affected.

Users are recommended to upgrade to version 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2023-42794?

5 open source packages ship an affected version, including org.apache.tomcat:tomcat-coyote and tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.85 | 8.5.94 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.85 | 8.5.94 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.70 | 9.0.81 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.70 | 9.0.81 |
| `tomcat` | Bitnami | From 8.5.85 | 8.5.94, 9.0.81 |

Products: Apache Tomcat.

## How do I fix CVE-2023-42794?

Upgrade org.apache.tomcat:tomcat-coyote to a fixed version for your release line: 8.5.94 or 9.0.81.

## Is CVE-2023-42794 being exploited?

There is no known exploitation of CVE-2023-42794 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42794 and fix it if it is affected.

What it is: CVE-2023-42794 is a medium-severity denial of service vulnerability in Apache Tomcat, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42794 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.85; fixed in 8.5.94
- org.apache.tomcat:tomcat-coyote (Maven): affected from 8.5.85; fixed in 8.5.94
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.70; fixed in 9.0.81
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.70; fixed in 9.0.81
- tomcat (Bitnami): affected from 8.5.85; fixed in 8.5.94, 9.0.81

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42794/ (Markdown: https://insights.sbomify.com/CVE-2023-42794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42794
- OSV: https://osv.dev/vulnerability/CVE-2023-42794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42794/
Summaries are generated and may contain mistakes; the official description above is the record.
