CVE-2023-42795 Apache Tomcat: Failure during request clean-up leads to sensitive data leaking to subsequent requests
Incomplete object cleanup in Apache Tomcat allows sensitive data from one request to leak into subsequent requests, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-42795?
CVE-2023-42795 is a medium-severity vulnerability in Apache Tomcat, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incomplete Cleanup vulnerability in Apache Tomcat.When recycling various internal objects in Apache Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.80 and from 8.5.0 through 8.5.93, an error could cause Tomcat to skip some parts of the recycling process leading to information leaking from the current request/response to the next. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.
Weakness: CWE-459
Which versions are affected by CVE-2023-42795?
33 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 8.5.94 |
27 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.81 |
tomcat Bitnami | From 8.5.0 | 8.5.94, 9.0.81, 10.1.14 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat:tomcat Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat-catalina Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat:tomcat-catalina Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat:tomcat-util Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat-util Maven | From 10.1.0-M1 | 10.1.14 |
org.apache.tomcat:tomcat-util Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat-util Maven | From 11.0.0-M1 | 11.0.0-M12 |
org.apache.tomcat:tomcat-util Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat-util Maven | From 8.5.0 | 8.5.94 |
org.apache.tomcat:tomcat-util Maven | From 9.0.0-M1 | 9.0.81 |
org.apache.tomcat:tomcat-util Maven | From 9.0.0-M1 | 9.0.81 |
Products include Apache Tomcat, Debian Debian Linux.
How do I fix CVE-2023-42795?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.14, 11.0.0-M12, 8.5.94 or 9.0.81.
Is CVE-2023-42795 being exploited?
There is no known exploitation of CVE-2023-42795 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2023-42795, CLSA-2025-1737569580, CLSA-2025-1739387678, CLSA-2025-1741286028, CLSA-2025-1765411677, DEBIAN-CVE-2023-42795 and 2 more.