# CVE-2023-42805: quinn-proto Denial of Service vulnerability

> Attackers can cause a denial of service by sending unknown QUIC frames, crashing the application using the quinn-proto library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** DEBIAN-CVE-2023-42805, GHSA-q8wc-j5m9-27w3, RUSTSEC-2023-0063, UBUNTU-CVE-2023-42805

## What is CVE-2023-42805?

CVE-2023-42805 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

quinn-proto is a state machine for the QUIC transport protocol. Prior to versions 0.9.5 and 0.10.5, receiving unknown QUIC frames in a QUIC packet could result in a panic. The problem has been fixed in 0.9.5 and 0.10.5 maintenance releases.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-42805?

3 open source packages ship an affected version, including quinn-proto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quinn-proto` | crates.io | All versions | 0.9.5 |
| `quinn-proto` | crates.io | All versions | 0.9.5 |
| `quinn-proto` | crates.io | From 0.0.0-0 | 0.9.5, 0.10.5 |

Products: Quinn Project Quinn.

## How do I fix CVE-2023-42805?

Upgrade quinn-proto to a fixed version for your release line: 0.9.5 or 0.10.5.

## Is CVE-2023-42805 being exploited?

There is no known exploitation of CVE-2023-42805 in the wild and no public exploit code.

## Other vulnerabilities in quinn-rs quinn

- [CVE-2024-45311](https://insights.sbomify.com/CVE-2024-45311/): Denial of service in quinn-proto when using `Endpoint::retry()` (high 7.5)
- [CVE-2021-28036](https://insights.sbomify.com/CVE-2021-28036/): quinn invalidly assumes the memory layout of std::net::SocketAddr (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-42805 and fix it if it is affected.

What it is: CVE-2023-42805 is a high-severity denial of service vulnerability in quinn-rs quinn, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-42805 in the wild and no public exploit code.

Affected packages and fixed versions:
- quinn-proto (crates.io): affected all versions; fixed in 0.9.5
- quinn-proto (crates.io): affected all versions; fixed in 0.9.5
- quinn-proto (crates.io): affected from 0.0.0-0; fixed in 0.9.5, 0.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-42805/ (Markdown: https://insights.sbomify.com/CVE-2023-42805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-42805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-42805
- OSV: https://osv.dev/vulnerability/CVE-2023-42805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-42805/
Summaries are generated and may contain mistakes; the official description above is the record.
